vm_page_flash man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

VM_PAGE_BUSY(9)		 BSD Kernel Developer's Manual	       VM_PAGE_BUSY(9)

NAME
     vm_page_busy, vm_page_flash, vm_page_wakeup — handle the busying and
     unbusying of a page

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_page.h>

     void
     vm_page_busy(vm_page_t m);

     void
     vm_page_flash(vm_page_t m);

     void
     vm_page_wakeup(vm_page_t m);

DESCRIPTION
     These functions handle the busying, unbusying and notification of the
     unbusying of a page.

     vm_page_busy() sets the VPO_BUSY flag in the page.

     vm_page_flash() checks to see if there is anybody waiting on the page
     (VPO_WANTED will be set), and if so, clears the VPO_WANTED flag and noti‐
     fies whoever is waiting via wakeup().

     vm_page_wakeup() clears the VPO_BUSY flag on the page, and calls
     vm_page_flash() in case somebody has been waiting for it.

SEE ALSO
     vm_page_sleep_if_busy(9), wakeup(9)

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 July 14, 2001				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net