vm_page_sleep_if_busy man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

VM_PAGE_SLEEP_IF_BUSY(9) BSD Kernel Developer's ManualVM_PAGE_SLEEP_IF_BUSY(9)

NAME
     vm_page_sleep_if_busy — wait for a busy page to become unbusy

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_page.h>

     int
     vm_page_sleep_if_busy(vm_page_t m, int also_m_busy, const char *wmesg);

DESCRIPTION
     The vm_page_sleep_if_busy() function waits until the VPO_BUSY flag is
     cleared.  If also_m_busy is non-zero, it also waits for m->busy to become
     zero.

RETURN VALUES
     If vm_page_sleep_if_busy() finds the page busy it returns TRUE.  If not,
     it returns FALSE.	Returning TRUE does not necessary mean that
     vm_page_sleep_if_busy() slept, but only that splvm() was called.

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 July 13, 2001				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net