NET_GETMTU(9F)NET_GETMTU(9F)NAMEnet_getmtu - determine the MTU of a given network interface
SYNOPSIS
#include <sys/neti.h>
int net_getmtu(const net_data_t net, const phy_if_t ifp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
net
value returned from a successful call to net_proto‐
col_lookup(9F).
ifp
value returned from a successful call to net_phylookup(9F) or
net_phygetnext(9F).
DESCRIPTION
The net_getmtu() function receives information about the current MTU of
a network interface. The value returned from this function call should
not be cached as the MTU of a network interface since it is not guaran‐
teed to be constant.
RETURN VALUES
The net_getmtu() function returns -1 if the network protocol does not
support this feature and otherwise returns the current MTU of the net‐
work interface.
CONTEXT
The net_getmtu() function may be called from user, kernel, or inter‐
rupt context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes:
┌────────────────────┬─────────────────┐
│ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
├────────────────────┼─────────────────┤
│Interface Stability │ Committed │
└────────────────────┴─────────────────┘
SEE ALSOnet_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F)
May 1, 2008 NET_GETMTU(9F)