VOP_STRATEGY man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

VOP_STRATEGY(9)		 BSD Kernel Developer's Manual	       VOP_STRATEGY(9)

NAME
     VOP_STRATEGY — read or write a file system buffer

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     int
     VOP_STRATEGY(struct vnode *vp, struct buf *bp);

DESCRIPTION
     The arguments are:

     vp	 The vnode that the buffer is for.

     bp	 The buffer to be read or written.

     This call either reads or writes data from a file, depending on the value
     of bp->b_io.bio_cmd.

     The call may block.

RETURN VALUES
     Always zero.  Errors should be signalled by setting BIO_ERROR on
     b_ioflags field in struct buf, and setting b_error to the appropriate
     errno value.

SEE ALSO
     vnode(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 July 24, 1996				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net