VOP_REVOKE man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

VOP_REVOKE(9)		 BSD Kernel Developer's Manual		 VOP_REVOKE(9)

NAME
     VOP_REVOKE — revoke access to a device and its aliases

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     int
     VOP_REVOKE(struct vnode *vp, int flags);

DESCRIPTION
     VOP_REVOKE() will administratively revoke access to the device specified
     by vp, as well as any aliases created via make_dev_alias(9).  Further
     file operations on any of these devices by processes which have them open
     will nominally fail.  The flags must be set to REVOKEALL to signify that
     all access will be revoked; any other value is invalid.

LOCKS
     The vp must be unlocked on entry, and will remain unlocked upon return.

SEE ALSO
     make_dev_alias(9), vnode(9)

AUTHORS
     This manual page was written by Brian Fundakowski Feldman.

BSD			       February 5, 2002				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net