VFS_SYNC man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

VFS_SYNC(9)		 BSD Kernel Developer's Manual		   VFS_SYNC(9)

NAME
     VFS_SYNC — flush unwritten data

SYNOPSIS
     #include <sys/param.h>
     #include <sys/mount.h>
     #include <sys/vnode.h>

     int
     VFS_SYNC(struct mount *mp, int waitfor);

DESCRIPTION
     The VFS_SYNC() macro writes out all unwritten data in the file system
     mounted as mp.

     The arguments it expects are:

     mp	      The file system.

     waitfor  Whether the function should wait for I/O to complete.  Possible
	      values are:

	      MNT_WAIT	  synchronously wait for I/O to complete

	      MNT_NOWAIT  start all I/O, but do not wait for it

	      MNT_LAZY	  push data not written by file system syncer

     The VFS_SYNC() macro calls the vfs_sync method of the file system, which
     normally calls VOP_FSYNC(9) for all the vnodes in the file system.

SEE ALSO
     fsync(2), sync(2), VFS(9), vnode(9), VOP_FSYNC(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 May 23, 2009				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net