vm_map_insert man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

VM_MAP_INSERT(9)	 BSD Kernel Developer's Manual	      VM_MAP_INSERT(9)

NAME
     vm_map_insert — insert an object into a map

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_map.h>

     int
     vm_map_insert(vm_map_t map, vm_object_t object, vm_ooffset_t offset,
	 vm_offset_t start, vm_offset_t end, vm_prot_t prot, vm_prot_t max,
	 int cow);

DESCRIPTION
     The vm_map_insert() function inserts a mapping for the entire vm_object
     object into the target map map.

     The offset argument specifies the offset into the object at which to
     begin mapping.  The object's size should match that of the specified
     address range.

     The start and end arguments specify the bounds of the mapped object's
     window in the address space of map.

     The cow argument specifies the flags which should be propagated to the
     new entry, for example, to indicate that this is a copy-on-write mapping.

IMPLEMENTATION NOTES
     This function implicitly creates a new vm_map_entry by calling the inter‐
     nal function vm_map_entry_create().  This function may use the Giant lock
     to ensure that only a single thread is present in the function.

RETURN VALUES
     The vm_map_insert() function returns KERN_SUCCESS if the mapping could be
     made successfully.

     Otherwise, KERN_INVALID_ADDRESS will be returned if the start of the
     range could not be found, or KERN_NO_SPACE if the range was found to be
     part of an existing entry or if it overlaps the end of the map.

SEE ALSO
     vm_map(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 19, 2003				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net