vfs_getvfs man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

VFS_GETVFS(9)		 BSD Kernel Developer's Manual		 VFS_GETVFS(9)

NAME
     vfs_getvfs — returns a mount point given its file system identifier

SYNOPSIS
     #include <sys/param.h>
     #include <sys/mount.h>

     struct mount *
     vfs_getvfs(fsid_t *fsid);

DESCRIPTION
     The vfs_getvfs() function returns the mount point structure for a file
     system given its file system identifier.  The file system ID should have
     been allocated by calling vfs_getnewfsid(9); otherwise, it will not be
     found.

     A major user of vfs_getvfs() is NFS, which uses the fsid as part of file
     handles in order to determine the file system a given RPC is for.	If
     vfs_getvfs() fails to find the mount point related to fsid, the file sys‐
     tem is considered stale.

RETURN VALUES
     If fsid is found, the mount point for the ID is returned; otherwise, NULL
     is returned.

PSEUDOCODE
     if ((mp = vfs_getvfs(&fhp->fh_fsid)) == NULL) {
	     error = ESTALE;
	     goto out;
     }

SEE ALSO
     vfs_getnewfsid(9)

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD			       November 21, 2001			   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net