vfs_aio_fork man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

VFS_AIO_FORK(1M)	  System Administration tools	      VFS_AIO_FORK(1M)

NAME
       vfs_aio_fork - implement async I/O in Samba vfs

SYNOPSIS
       vfs objects = aio_fork

DESCRIPTION
       This VFS module is part of the samba(7) suite.

       The aio_fork VFS module enables async I/O for Samba on platforms where
       the system level Posix AIO interface is insufficient. Posix AIO can
       suffer from severe limitations. For example, on some Linux versions the
       real-time signals that it uses are broken under heavy load. Other
       systems only allow AIO when special kernel modules are loaded or only
       allow a certain system-wide amount of async requests being scheduled.
       Systems based on glibc (most Linux systems) only allow a single
       outstanding request per file descriptor.

       To work around all these limitations, the aio_fork module was written.
       It uses forked helper processes instead of the internal Posix AIO
       interface to create asynchronousity for read and write calls. It has no
       parameters, it will create helper processes when async requests come in
       as needed. Idle helper processes will be removed every 30 seconds.

       This module is stackable.

EXAMPLES
       Straight forward use:

		   [cooldata]
		path = /data/ice
		vfs objects = aio_fork

VERSION
       This man page is correct for version 3.6.0 of the Samba suite.

AUTHOR
       The original Samba software and related utilities were created by
       Andrew Tridgell. Samba is now developed by the Samba Team as an Open
       Source project similar to the way the Linux kernel is developed.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────────────────────┐
       │  ATTRIBUTE TYPE    │	      ATTRIBUTE VALUE	      │
       ├────────────────────┼─────────────────────────────────┤
       │Availability	    │ SUNWsmbar, SUNWsmbac, SUNWsmbau │
       ├────────────────────┼─────────────────────────────────┤
       │Interface Stability │ External			      │
       └────────────────────┴─────────────────────────────────┘
NOTES
       Source code for Samba is available in the SUNWsmbaS package.

       Samba(7) delivers the set of four SMF(5) services as can be seen from
       the following example:

	    $ svcs samba wins winbind swat
	   STATE	  STIME	   FMRI
	   disabled	  Apr_21   svc:/network/samba:default
	   disabled	  Apr_21   svc:/network/winbind:default
	   disabled	  Apr_21   svc:/network/wins:default
	   disabled	  Apr_21   svc:/network/swat:default

       where the services are:

	"samba"
	   runs the smbd daemon managing the CIFS sessions

	"wins"
	   runs the nmbd daemon enabling the browsing (WINS)

	"winbind"
	   runs the winbindd daemon making the domain idmap

	"swat"
	   Samba Web Administration Tool is a service providing access to
	   browser-based Samba administration interface and on-line
	   documentation.  The service runs on software loopback network
	   interface on port 901/tcp, i.e. opening "http://localhost:901/" in
	   browser will access the SWAT service on local machine.

       Please note: SWAT uses HTTP Basic Authentication scheme where user name
       and passwords are sent over the network in clear text. In the SWAT case
       the user name is root. Transferring such sensitive data is advisable
       only on the software loopback network interface or over secure
       networks.

Samba 3.6			  04/10/2012		      VFS_AIO_FORK(1M)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net