usbwcm man page on OpenIndiana

Man page or keyword search:  
man Server   20441 pages
apropos Keyword Search (all sections)
Output format
OpenIndiana logo
[printable version]

usbwcm(7M)			STREAMS Modules			    usbwcm(7M)

NAME
       usbwcm - STREAMS module for Wacom USB Tablets

SYNOPSIS
       # include <sys/usb/clients/usbinput/usbwcm/usbwcm.h>

DESCRIPTION
       The  usbwcm  STREAMS module processes byte streams generated by a Wacom
       USB tablet.

       The usbwcm module must be pushed on top of the HID  class  driver.  See
       hid(7D).	 The  usbwcm module translates data from Wacom USB tablet into
       formatted events expected by Wacom X.org XInputdriver. The event struc‐
       ture is the same as that of FreeBSD uwacom driver.

   Event Structure
       The	  event_input	    structure	    is	     defined	   in:
       usr/include/sys/usb/clients/usbinput/usbwcm/usbwcm.h

	    struct event_input {
	 #if defined(_LP64) || defined(_I32LPx)
	       struct timeval32 time;
	 #else
	       struct timeval time;
	 #endif
	       uint16_t type;
	       uint16_t index;
	       int32_t value;
	    };

       time	The event's timestamp. When the event occurred. The  timestamp
		is  not defined to be meaningful except by being compared with
		other input event timestamps.

       type	The event's unique type: button,  relative/absolute  valuator,
		sync,  and  so	forth.	type  is among the following: EVT_SYN,
		EVT_BTN, EVT_REL, EVT_ABS and EVT_MSC.

       index	The event's sub-type. The index in a button  event  identifies
		which	button	 status	 was  changed.	Typical	 button	 index
		includes:   BTN_LEFT,	BTN_RIGHT,    BTN_MIDDLE,    BTN_SIDE,
		BTN_EXTRA,    BTN_TOOL_PEN,   BTN_TOOL_ERASER,	 BTN_TOOL_PAD,
		BTN_TOOL_MOUSE, BTN_TIP, BTN_STYLUS_1, BTN_STYLUS_2

		For absolute valuators, index is among the  following:	ABS_X,
		ABS_Y,	 ABS_Z,	  ABS_RX,   ABS_RY,  ABS_WHEEL,	 ABS_PRESSURE,
		ABS_DISTANCE, ABS_TILT_X, ABS_TILT_Y, and ABS_MISC.

   Ioctls
       EVTIOCGVERSION	 The argument is a pointer  to	an  int.  This	option
			 returns  the  current	version of the event interface
			 implemented by the STREAMS module.

       EVTIOCGDEVID	 The argument is a pointer to event_dev_id  structure.
			 This ioctl returns the identifiers of the device.

			   struct event_dev_id {
			   uint16_t bus;
			   #defineID_BUS_USB 3
			   uint16_t vendor;
			   uint16_t product;
			   uint16_t version;
			   };

       EVTIOCGBM	 The  argument is a pointer to an variable-length char
			 array. This ioctl returns the event types reported by
			 device:

			 EVT_SYN, EVT_BTN, EVT_REL, EVT_ABS, EVT_MSC

       EVTIOCGABS	 The argument is a pointer to an event_abs_axis struc‐
			 ture. This ioctl returns the ranges, and other param‐
			 eters for the specified axis.

			   struct event_abs_axis {
			   int32_t value;
			   int32_t min;
			   int32_t max;
			   int32_t fuzz;
			   int32_t flat;
			   };

FILES
       /kernel/strmod/usbwcm

	   32-bit ELF kernel STREAMS module

       /kernel/strmod/amd64/usbwcm

	   64-bit ELF kernel STREAMS module

       /kernel/strmod/sparcv9/usbwcm

	   SPARC 64-bit ELF kernel STREAMS module

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Architecture		     │SPARC, x86-based systems	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability		     │driver/usb		   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       ioctl(2), attributes(5), hid(7D)

       System Administration Guide: Basic Administration

       http://linuxwacom.sourceforge.net

       http://www.sun.com

SunOS 5.11			  15 Jan 2010			    usbwcm(7M)
[top]

List of man pages available for OpenIndiana

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net