usbsprl man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

usbsprl(7D)			    Devices			   usbsprl(7D)

NAME
       usbsprl - Prolific PL2303 USB to serial converter driver

SYNOPSIS
       #include <fcntl.h>

       #include <sys/termio.h>

       usbsprl@unit

DESCRIPTION
       The usbsprl driver is a loadable STREAMS and USBA  (Solaris USB	archi‐
       tecture) compliant client driver that provides basic asynchronous  com‐
       munication  support  for Prolific PL2303 USB-to-serial converters. Sup‐
       ported devices include PL2303H, PL2303HX and  PL2303X.	Serial	device
       streams	are  built  with  appropriate modules that are pushed atop the
       usbsprl driver by the autopush(1M) facility.

       The usbsprl module supports the	termio(7I)  device  control  functions
       specified by flags in the c_cflag word of the termios structure, and by
       the IGNBRK,  IGNPAR,  PARMRK and INPCK flags in the c_iflag word of the
       termios	structure. All other termio(7I) functions must be performed by
       STREAMS modules pushed atop the driver. When a device  is  opened,  the
       ldterm(7M)  and	ttcompat(7M)  STREAMS modules are automatically pushed
       on top of the stream, providing the standard termio(7I) interface.

       Use device logical  names  /dev/term/[0-9]*   to	  access   the	serial
       ports. These names are typically used to provide a logical access point
       for a dial-in line that is used with a modem.

       A special feature (controlled by the minor device number) is  available
       that  enables a single tty line to be connected to a modem and used for
       incoming and outgoing calls. By accessing through device	 logical  name
       /dev/cua/[0-9]*, you can open a port without  the carrier detect signal
       being asserted, either through hardware or an equivalent software mech‐
       anism. These devices are commonly known as  'dial-out' lines.

       Unlike onboard serial ports, the usbsprl ports  cannot serve as a local
       serial console.

APPLICATION PROGRAMMING INTERFACE
       A dial-in line can be opened only if the corresponding dial-out line is
       closed.	A  blocking  /dev/term	open  waits until the /dev/cua line is
       closed (which drops Data Terminal Ready,	 after	which  Carrier	Detect
       usually	drops  as well) and carrier is detected again.	A non-blocking
       /dev/term open returns an error if the /dev/cua is open.

       If the /dev/term line is opened successfully  (usually  only when  car‐
       rier  is recognized on the modem), the corresponding /dev/cua line can‐
       not be opened. This allows a modem and port to be used  for dial-in (by
       enabling the line for login in /etc/inittab) or dial-out (by tip(1), or
       uucp(1C)) when no one is logged in on the line.

       Device hot-removal  is functionally equivalent to  a  modem  disconnect
       event, as defined in termio(7I).

IOCTLS
       The   usbsprl  driver  supports	the   standard set of termio(7I) ioctl
       calls.

       Input and output line speeds can be set to the  following  baud	rates:
       75,  150,  300, 600, 1200, 1800, 2400, 4800, 9600, 19200, 38400, 57600,
       115200, 230400 or 460800.  Input and output line speeds cannot  be  set
       independently.  For  example,  when  the output speed is set, the input
       speed is automatically set to the same speed.

ERRORS
       An open() fails under the following conditions:

       ENXIO		       The  unit being opened does not exist.

       EBUSY		       The /dev/cua (dial-out) device is being	opened
			       while   the /dev/term (dial-in device) is open,
			       or the dial-in device is being  opened  with  a
			       no-delay	 open  while  the  dial-out  device is
			       open.

       EBUSY		       The  unit has been marked as  exclusive-use  by
			       another	process with a TIOCEXCL ioctl() call.

       EIO		       USB device I/O error.

FILES
       /kernel/drv/usbsprl

	   32-bit x86 ELF kernel module.

       /kernel/drv/amd64/usbsprl

	   64-bit x86 ELF kernel module.

       /kernel/drv/sparcv9/usbsprl

	   64-bit SPARC ELF kernel module.

       /dev/cua/[0-9]*

	   dial-out tty lines.

       /dev/term/[0-9]*

	   dial-in tty lines.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬──────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	     ATTRIBUTE VALUE	    │
       ├─────────────────────────────┼──────────────────────────────┤
       │Architecture		     │SPARC, x86, PCI-based systems │
       ├─────────────────────────────┼──────────────────────────────┤
       │Availability		     │SUNWuprl			    │
       └─────────────────────────────┴──────────────────────────────┘

SEE ALSO
       strconf(1),   tip(1),   uucp(1C),   autopush(1M),   ioctl(2),  open(2),
       termios(3C), attributes(5), usba(7D),  termio(7I),  ldterm(7M),	ttcom‐
       pat(7M)

DIAGNOSTICS
       In  addition  to being logged, the following messages may appear on the
       system console. All messages are formatted in the following manner:

       Warning: <device path> (usbsprl<instance num>): Error Message...

       Device was disconnected while open. Data may have been lost.

	   The device has been hot-removed or powered off while	 it  was  open
	   and	a  possible  data  transfer  was  in  progress. The job may be
	   aborted.

       Device is not identical to the previous one on this port.  Please  dis‐
       connect and reconnect.

	   The	device	was  hot-removed  while	 open.	A new device  was hot-
	   inserted which is not identical to the original device. Please dis‐
	   connect  the	 device	 and reconnect the original device to the same
	   port.

       Device has been reconnected, but data may have been lost.

	   The device that was hot-removed from its  USB  port	has  been  re-
	   inserted  again  to	the  same port. It is available for access but
	   data from a	previou transfer may be lost.

       Cannot access <device>. Please reconnect.

	   This device has been disconnected because a device other  than  the
	   original one has been inserted. The driver informs you of this fact
	   by displaying the name of  the original device.

       The following messages may be logged into the system log. They are for‐
       matted in the following manner:

       <device path><usbsprl<instance number>): message...

       Input overrun

	   Data was lost.

SunOS 5.10			  18 Oct 2005			   usbsprl(7D)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net