usb_pipe_get_max_bulk_transfer_size man page on OpenIndiana

Man page or keyword search:  
man Server   20441 pages
apropos Keyword Search (all sections)
Output format
OpenIndiana logo
[printable version]

usb_pipe_get_max_bulk_traKernelsFunctiousb_pipe_get_max_bulk_transfer_size(9F)

NAME
       usb_pipe_get_max_bulk_transfer_size - Get maximum bulk transfer size

SYNOPSIS
       #include <sys/usb/usba.h>

       int usb_pipe_get_max_bulk_transfer_size(dev_info_t dip, size_t *size);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

PARAMETERS
       dip     Pointer to the device's dev_info structure.

       size    Returns the bulk transfer size.

DESCRIPTION
       The  usb_pipe_get_max_bulk_transfer_size() function returns the maximum
       data transfer size in bytes that the host controller driver can support
       per  bulk  request. This information can be used to limit or break down
       larger requests to manageable sizes.

RETURN VALUES
       USB_SUCCESS	   Size is returned in size argument.

       USB_INVALID_ARGS	   dip and/or size argument is NULL.

       USB_FAILURE	   Size could not be returned.	Zero  is  returned  in
			   size arg.

CONTEXT
       May be called from user, kernel or interrupt context.

EXAMPLES
	     int xxx_attach(dev_info_t *dip, int command)
	     {
		    ...
		    usb_pipe_get_max_bulk_transfer_size(dip, &state>max_xfer_size);
		    ...
	     }

	     void xxx_minphys(struct buf bp)
	     {
		    ...
		    if (bp->b_bcount > state->max_xfer_size) {
			    bp->b_bcount = state->max_xfer_size;
		    }
		    ...
	     }

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Architecture		     │PCI-based systems		   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Committed			   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability		     │driver/usb		   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       attributes(5),	   usb_pipe_bulk_xfer(9F),	usb_alloc_request(9F),
       usb_bulk_request(9S)

SunOS 5.11			  5 Janusb_pipe_get_max_bulk_transfer_size(9F)
[top]

List of man pages available for OpenIndiana

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net