usb_get_max_pkts_per_isoc_request man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

usb_get_max_pkts_per_isocKernelsFunctionsusb_get_max_pkts_per_isoc_request(9F)

NAME
       usb_get_max_pkts_per_isoc_request  -  Get  maximum  number  of  packets
       allowed per isochronous request

SYNOPSIS
       #include <sys/usb/usba.h>

       uint_t usb_get_max_pkts_per_isoc_request(dev_info_t *dip);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

PARAMETERS
       dip

	   Pointer to the device's dev_info structure.

DESCRIPTION
       The usb_get_max_pkts_per_isoc_request() function	 returns  the  maximum
       number  of isochronous packets per request that the host control driver
       can support. This number can be used to determine the maximum amount of
       data  which  can	     be handled by a single isochronous request.  That
       length is found by:

       max = usb_get_max_pkts_per_isoc_request(dip) * endpoint_max_packet_size;

       where endpoint_max_packet_size  is  the	wMaxPacketSize	field  of  the
       isochronous endpoint over which the transfer will take	     place.

RETURN VALUES
       On  success,  the  usb_get_current_frame_number()  function returns the
       maximum number of isochronous pkts per request. On failure  it  returns
       0. The function fails if dip is NULL.

CONTEXT
       May be called from user, kernel or interrupt context.

EXAMPLES
       /*
	* Set up to receive periodic isochronous data, requesting
	* the maximum amount for each transfer.
	*/

       int pkt;
       /* Get max packet size from endpoint descriptor. */
       uint_t ep_max_pkt_size = ep_descr.wMaxPacketSize;
       uint_t isoc_pkts_count = usb_get_max_pkts_per_isoc_request(dip);

       /*
	* Allocate an isoc request, specifying the max number of packets
	* and the greatest size transfer possible.
	*/
       usb_isoc_req_t *isoc_req = usb_alloc_isoc_req(dip,
	   isoc_pkts_count,
	   isoc_pkts_count * ep_max_pkt_size,
	   USB_FLAGS_SLEEP);

       /* Init each packet descriptor for maximum size. */
       for (pkt = 0; pkt < isoc_pkts_count; pkt++) {
	   isoc_req->isoc_pkt_descr[pkt].isoc_pkt_length = ep_max_pkt_size;

       }

       /* Set the length of a packet in the request too. */
       isoc_req->isoc_pkts_length = ep_max_pkt_size;

       /* Other isoc request initialization. */
       ...
       ...

       if (usb_pipe_isoc_xfer(pipe, isoc_req, USB_FLAGS_NOSLEEP) != USB_SUCCESS) {
	   ...
       }

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Architecture		     │PCI-based systems		   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface stability	     │Evolving			   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability		     │SUNWusb			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       attributes(5),	   usb_pipe_isoc_xfer(9F),	usb_alloc_request(9F),
       usb_get_current_frame_number(9F).		     usb_ep_descr(9S),
       usb_isoc_request(9S)

SunOS 5.10			  5 Jan 2usb_get_max_pkts_per_isoc_request(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net