usb_get_current_frame_number man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

usb_get_current_frame_numKernel)Functions for usb_get_current_frame_number(9F)

NAME
       usb_get_current_frame_number - Return current logical usb frame number

SYNOPSIS
       #include <sys/usb/usba.h>

       usb_frame_number_t usb_get_current_frame_number(dev_info_t *dip);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

PARAMETERS
       dip

	   Pointer to the device's dev_info structure.

DESCRIPTION
       The usb_get_current_frame_number() function retrieves the current logi‐
       cal USB frame number.

       Isochronous requests can be started on a particular numbered frame.  An
       offset  number  of  frames (typically between 4 and 10) can be added to
       the current logical frame number to specify the number of  an  upcoming
       frame to start an isochronous request.

       The  USB	 specification	requires  that the frame frequency (the period
       between start-of-frame packets) is one millisecond.  The Solaris	 oper‐
       ating environment USB implementation uses a running counter of the num‐
       ber of milliseconds since boot as the current logical frame number.

RETURN VALUES
       On success, the	usb_get_current_frame_number()	function  returns  the
       current	USB  frame number. On failure it returns 0. The function fails
       if dip is NULL.

CONTEXT
       May be called from user, kernel or interrupt context.

EXAMPLES
	   usb_pipe_handle_t handle;
	   usb_frame_number_t offset = 10;
	   usb_isoc_req_t *isoc_req;

	   isoc_req = usb_alloc_isoc_req(...);
	     ...
	     ...
	   isoc_req->isoc_frame_no = usb_get_current_frame_number(dip) + offset;
	   isoc_req->isoc_attributes = USB_ATTRS_ISOC_START_FRAME;
	     ...
	     ...
	   if (usb_pipe_isoc_xfer(handle, isoc_req, 0) != USB_SUCCESS) {
	     ...
	   }

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Architecture		     │PCI-based systems		   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface stability	     │Evolving			   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability		     │SUNWusb			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       attributes(5),				       usb_alloc_isoc_req(9F),
       usb_get_max_pkts_per_isoc_request(9F),	       usb_pipe_isoc_xfer(9F),
       usb_pipe_get_max_bulk_transfer_size(9F), usb_isoc_request(9S)

SunOS 5.10			 25 July 2004 usb_get_current_frame_number(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net