scsi_hba_pkt_comp man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

scsi_hba_pkt_comp(9F)	 Kernel Functions for Drivers	 scsi_hba_pkt_comp(9F)

NAME
       scsi_hba_pkt_comp - scsi_pkt completion routine

SYNOPSIS
       #include <sys/scsi/scsi.h>

       void scsi_hba_pkt_comp(struct scsi_pkt *pkt);

PARAMETERS
       pkt    Pointer to a scsi_pkt(9S) structure.

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

DESCRIPTION
       After  filling  in  scsi_pkt(9S) fields with packet completion informa‐
       tion, an HBA driver should call the scsi_hba_pkt_comp() function.  This
       function	 is the recommended way for an HBA driver to signal completion
       of a scsi_pkt structure.

       Calling the scsi_hba_pkt_comp() function allows SCSA  to	 observe,  and
       possibly react to, the completion of a scsi_pkt request.

       A call to the scsi_hba_pkt_comp() function will always result in a call
       to the pkt_comp()  callback  function  defined  in  scsi_pkt(9S).  This
       pkt_comp()   callback   may,   however,	 occur	 after	 return	  from
       scsi_hba_pkt_comp(), and may occur from a different thread executing on
       a different CPU.

CONTEXT
       The scsi_hba_pkt_comp() function can be called from user, interrupt, or
       kernel context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Committed			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       attributes(5), scsi_pkt(9S)

NOTES
       HBA driver calls scsi_hba_pkt_comp() instead  of	 calling  scsi_pkt(9S)
       pkt_comp directly.

SunOS 5.10			  29 Jan 2009		 scsi_hba_pkt_comp(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net