pci_plist_lookup man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

pci_plist_lookup(9F)	 Kernel Functions for Drivers	  pci_plist_lookup(9F)

NAME
       pci_plist_lookup,     pci_plist_lookup_int8,    pci_plist_lookup_uint8,
       pci_plist_lookup_int16,			      pci_plist_lookup_uint16,
       pci_plist_lookup_int32,			      pci_plist_lookup_uint32,
       pci_plist_lookup_int64,			      pci_plist_lookup_uint64,
       pci_plist_lookup_string,			       pci_plist_lookup_plist,
       pci_plist_lookup_int8_array,		 pci_plist_lookup_uint8_array,
       pci_plist_lookup_int16_array,		pci_plist_lookup_uint16_array,
       pci_plist_lookup_int32_array,		pci_plist_lookup_uint32_array,
       pci_plist_lookup_int64_array,		pci_plist_lookup_uint64_array,
       pci_plist_lookup_string_array - name-value pair lookup functions

SYNOPSIS
       #include <sys/sunddi.h>

       int pci_plist_lookup_int8(pci_plist_t plist, const char *name,
	    int8_t *val);

       int pci_plist_lookup_uint8(pci_plist_t plist, const char *name,
	    uint8_t *val);

       int pci_plist_lookup_int16(pci_plist_t plist, const char *name,
	    int16_t *val);

       int pci_plist_lookup_uint16(pci_plist_t plist, const char *name,
	    uint16_t *val);

       int pci_plist_lookup_int32(pci_plist_t plist, const char *name,
	    int32_t *val);

       int pci_plist_lookup_uint32(pci_plist_t plist, const char *name,
	    uint32_t *val);

       int pci_plist_lookup_int64(pci_plist_t plist, const char *name,
	    int64_t *val);

       int pci_plist_lookup_uint64(pci_plist_t plist, const char *name,
	    uint64_t *val);

       int pci_plist_lookup_string(pci_plist_t plist, const char *name,
	    char **val);

       int pci_plist_lookup_plist(pci_plist_t plist, const char *name,
	    pci_plist_t **val);

       int pci_plist_lookup_int8_array(pci_plist_t plist, const char *name,
	    int8_t *val, uint_t *nelem);

       int pci_plist_lookup_uint8_array(pci_plist_t plist, const char *name,
	    uint8_t *val, uint_t *nelem);

       int pci_plist_lookup_int16_array(pci_plist_t plist, const char *name,
	    int16_t *val, uint_t *nelem);

       int pci_plist_lookup_uint16_array(pci_plist_t plist, const char *name,
	    uint16_t *val, uint_t *nelem);

       int pci_plist_lookup_int32_array(pci_plist_t plist, const char *name,
	    int32_t *val, uint_t *nelem);

       int pci_plist_lookup_uint32_array(pci_plist_t plist, const char *name,
	    uint32_t *val, uint_t *nelem);

       int pci_plist_lookup_int64_array(pci_plist_t plist, const char *name,
	    int64_t *val, uint_t *nelem);

       int pci_plist_lookup_uint64_array(pci_plist_t plist, const char *name,
	    uint64_t *val, uint_t *nelem);

       int pci_plist_lookup_string_array(pci_plist_t plist, const char *name,
	    char **val, uint_t *nelem);

PARAMETERS
       plist	A    handle	obtained     from     pci_plist_get(9F)	    or
		pci_plist_getvf(9F).

       name	Name of the name-value pair to search

       nelem	Address to store the number of elements in value

       val	Address to store the starting address of the value

DESCRIPTION
       These functions find the nvpair (name-value pair) that matches the name
       and type as indicated by the interface name. If one is found, nelem and
       val  are	 modified  to  contain the number of elements in value and the
       starting address of data, respectively.

RETURN VALUES
       These functions return 0 on success and an error value on failure.

ERRORS
       These functions will fail if:

       DDI_EINVAL    There is an invalid argument.

       ENOENT	     No matching name-value pair is found

       ENOTSUP	     An encode/decode method is not supported.

CONTEXT
       These functions can be called from kernel non-interrupt context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Uncommitted		   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       attributes(5),  pci_plist_get(9F),  pci_plist_getvf(9F),	  pciv_vf_con‐
       fig(9F), pci_param_get_ioctl(9F)

SunOS 5.10			  19 May 2011		  pci_plist_lookup(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net