pci_plist_get man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

pci_plist_get(9F)	 Kernel Functions for Drivers	     pci_plist_get(9F)

NAME
       pci_plist_get - get the name-value pair list for the PF device

SYNOPSIS
       #include <sys/sunddi.h>

       int pci_plist_get(pci_param_t param, pci_plist_t *plist_p);

PARAMETERS
       param	  A	handle	   obtained    from    pci_param_get(9F)    or
		  pci_param_get_ioctl(9F).

       plist_p	  A  pointer  to  pci_plist_t  where  a	 non—null  plist_p  is
		  returned on successful return

DESCRIPTION
       The plist_p returned by pci_plist_get() is similar to nvlist_t and con‐
       tains the name-value pairs for the PF (Physical Function)  device.  The
       pci_plist_t supports the following data types:

	 int8_t, uint8_t, int16_t, uint16_t, int32_t, uint32_t, int64_t,
	 uint64_t, char *, pci_plist_t

       Arrays of the above data types are supported except pci_plist_t.

RETURN VALUES
       DDI_SUCCESS	 On success.

       Non-zero value	 There is no name-value list for PF device.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Uncommitted		   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       attributes(5),	       pci_param_free(9F),	    pci_param_get(9F),
       pci_plist_getvf(9F)

SunOS 5.10			  19 May 2011		     pci_plist_get(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net