pci_param_free man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

pci_param_free(9F)	 Kernel Functions for Drivers	    pci_param_free(9F)

NAME
       pci_param_free  -  free	resources  allocated  by  pci_param_get()  and
       pci_param_get_ioctl()

SYNOPSIS
       #include <sys/sunddi.h>

       int pci_param_free(pci_param_t param);

PARAMETERS
       param	A     handle	 obtained     from     pci_param_list()	    or
		pci_param_get_ioctl().

DESCRIPTION
       The   pci_param_free()	function  frees	 the  resources	 allocated  by
       pci_param_get(9F) and pci_param_get_ioctl(9F). This  function  must  be
       called by the device driver after obtaining the device parameters using
       the param handle.

RETURN VALUES
       DDI_SUCCESS	 Successful completion.

       Non-zero value	 The param handle passed is invalid.

CONTEXT
       The pci_param_free() function can be called from	 kernel	 non-interrupt
       context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Uncommitted		   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       attributes(5), pci_param_get(9F), pci_param_get_ioctl(9F)

SunOS 5.10			  19 May 2011		    pci_param_free(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net