nvlist_lookup_nvlist man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

nvlist_lookup_boolean(9F)Kernel Functions for Driversnvlist_lookup_boolean(9F)

NAME
       nvlist_lookup_boolean, nvlist_lookup_boolean_value, nvlist_lookup_byte,
       nvlist_lookup_int8,	nvlist_lookup_int16,	  nvlist_lookup_int32,
       nvlist_lookup_int64,	nvlist_lookup_uint8,	 nvlist_lookup_uint16,
       nvlist_lookup_uint32,	nvlist_lookup_uint64,	 nvlist_lookup_string,
       nvlist_lookup_nvlist,			  nvlist_lookup_boolean_array,
       nvlist_lookup_byte_array,		     nvlist_lookup_int8_array,
       nvlist_lookup_int16_array,		    nvlist_lookup_int32_array,
       nvlist_lookup_int64_array,		    nvlist_lookup_uint8_array,
       nvlist_lookup_uint16_array,		   nvlist_lookup_uint32_array,
       nvlist_lookup_uint64_array,		   nvlist_lookup_string_array,
       nvlist_lookup_nvlist_array,  nvlist_lookup_pairs	 - match name and type
       indicated by the interface name and retrieve data value

SYNOPSIS
       #include <sys/nvpair.h>

       int nvlist_lookup_boolean(nvlist_t *nvl, const char *name);

       int nvlist_lookup_boolean_value(nvlist_t *nvl, const char *name,	 bool‐
       ean_t *val);

       int nvlist_lookup_byte(nvlist_t *nvl, const char *name, uchar_t *val);

       int nvlist_lookup_int8(nvlist_t *nvl, const char *name, int8_t *val);

       int nvlist_lookup_uint8(nvlist_t *nvl, const char *name, uint8_t *val);

       int nvlist_lookup_int16(nvlist_t *nvl, const char *name, int16_t *val);

       int  nvlist_lookup_uint16(nvlist_t  *nvl,  const	 char  *name, uint16_t
       *val);

       int nvlist_lookup_int32(nvlist_t *nvl, const char *name, int32_t *val);

       int nvlist_lookup_uint32(nvlist_t  *nvl,	 const	char  *name,  uint32_t
       *val);

       int nvlist_lookup_int64(nvlist_t *nvl, const char *name, int64_t *val);

       int  nvlist_lookup_uint64(nvlist_t  *nvl,  const	 char  *name, uint64_t
       *val);

       int nvlist_lookup_string(nvlist_t *nvl, const char *name, char **val);

       int nvlist_lookup_nvlist(nvlist_t  *nvl,	 const	char  *name,  nvlist_t
       **val);

       int  nvlist_lookup_boolean_array(nvlist_t *nvl, const char *name, bool‐
       ean_t **val, uint_t *nelem);

       int nvlist_lookup_byte_array(nvlist_t *nvl, const char  *name,  uchar_t
       **val, uint_t *nelem);

       int  nvlist_lookup_int8_array(nvlist_t  *nvl,  const char *name, int8_t
       **val, uint_t *nelem);

       int nvlist_lookup_uint8_array(nvlist_t *nvl, const char *name,  uint8_t
       **val, uint_t *nelem);

       int  nvlist_lookup_int16_array(nvlist_t *nvl, const char *name, int16_t
       **val, uint_t *nelem);

       int  nvlist_lookup_uint16_array(nvlist_t	 *nvl,	 const	 char	*name,
       uint16_t **val, uint_t *nelem);

       int  nvlist_lookup_int32_array(nvlist_t *nvl, const char *name, int32_t
       **val, uint_t *nelem);

       int  nvlist_lookup_uint32_array(nvlist_t	 *nvl,	 const	 char	*name,
       uint32_t **val, uint_t *nelem);

       int  nvlist_lookup_int64_array(nvlist_t *nvl, const char *name, int64_t
       **val, uint_t *nelem);

       int  nvlist_lookup_uint64_array(nvlist_t	 *nvl,	 const	 char	*name,
       uint64_t **val, uint_t *nelem);

       int  nvlist_lookup_string_array(nvlist_t	 *nvl,	const char *name, char
       ***val, uint_t *nelem);

       int  nvlist_lookup_nvlist_array(nvlist_t	 *nvl,	 const	 char	*name,
       nvlist_t ***val, uint_t *nelem);

       int nvlist_lookup_pairs(nvlist_t *nvl, int flag, ...);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

PARAMETERS
       nvl	       The  list  of  name-value  pairs	 (nvlist_t) to be pro‐
		       cessed.

       name	       Name of the name-value pair (nvpair) to search.

       nelem	       Address to store the number of elements in value.

       val	       Address to store the value or starting address  of  the
		       array value.

       flag	       Specify bit fields defining lookup behavior:

		       NV_FLAG_NOENTOK

			   The	retrival function will not fail if no matching
			   name-value pair is found.

DESCRIPTION
       These functions find the nvpair that matches the name and type as indi‐
       cated  by  the interface name. If one is found, nelem and val are modi‐
       fied to contain the number  of  elements	 in  value  and	 the  starting
       address of data, respectively.

       These  interfaces  work	for  nvlist_t allocated with NV_UNIQUE_NAME or
       NV_UNIQUE_NAME_TYPE specified in nvlist_alloc(). See  nvlist_alloc(9F).
       If  this is not the case, the interface will return ENOTSUP because the
       list potentially contains multiple nvpairs with the same name and type.

       Multiple threads can simultaneously read the same nvlist_t but only one
       thread should actively change a given nvlist_t at a time. The caller is
       responsible for the synchronization.

       All memory required for storing the array  elements,  including	string
       values,	are  managed  by  the  library. References to such data remain
       valid until nvlist_free() is called on nvl.

       The nvlist_lookup_pairs() function retrieves  a	set  of	 nvpairs.  The
       arguments   are	 a   null-terminated   list   of   pairs   (data  type
       DATA_TYPE_BOOLEAN), triples (non-array data types) or quads (array data
       types).	As shown below, the interpretation of the arguments depends on
       the value of type. See nvpair_type(9F).

       name	       Name of the name-value pair to search.

       type	       Data type.

       val	       Address to store the starting  address  of  the	value.
		       When  using  data type DATA_TYPE_BOOLEAN, the val argu‐
		       ment is ignored.

       nelem	       Address to store the number of elements in value.  Non-
		       array  data  types  have only one argument and nelem is
		       ignored.

       The argument order is name, type, [val], [nelem].

       When using NV_FLAG_NOENTOK and no matching name-value  pair  is	found,
       the memory pointed to by val and nelem is not touched.

       These functions return 0 on success and an error value on failure.

ERRORS
       These functions fail under the following conditions.

       0	       Success

       EINVAL	       Invalid argument

       ENOENT	       No matching name-value pair found

       ENOTSUP	       Encode/decode method not supported

CONTEXT
       These functions can be called from user, interrupt, or kernel context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Evolving			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       nvlist_alloc(9F), nvpair_type(9F)

       Writing Device Drivers

       STREAMS Programming Guide

SunOS 5.10			  20 May 2006	     nvlist_lookup_boolean(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net