nge man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

nge(7D)				    Devices			       nge(7D)

NAME
       nge  -  Gigabit	Ethernet  driver  for Nvidia Gigabit family of network
       interface controllers

SYNOPSIS
       /dev/nge

DESCRIPTION
       The nge Gigabit Ethernet driver is a  multi-threaded,  loadable,	 clon‐
       able,   GLD v3-based  STREAMS  driver supporting the Data Link Provider
       Interface dlpi(7P), on Nvidia ck8-04/mcp55/mcp51 Gigabit Ethernet  con‐
       trollers. The controller is a Mac chipset that works with PHY functions
       and provides three-speed (copper) Ethernet operation on the RJ-45  con‐
       nectors.

       The  nge	 driver	 functions  include  controller	 initialization, frame
       transmit and receive, promiscuous  and  multicast  support,  and	 error
       recovery and reporting.

       The nge driver and hardware support auto-negotiation, a protocol speci‐
       fied by the 1000 Base-T standard. Auto-negotiation allows  each	device
       to  advertise  its  capabilities	 and  discover those of its peer (link
       partner). The highest common denominator supported by both  link	 part‐
       ners   is  automatically	 selected,  yielding  the  greatest  available
       throughput while requiring no manual configuration. The nge driver also
       allows  you  to	configure the advertised capabilities to less than the
       maximum (where the full speed of the interface is not required), or  to
       force  a specific mode of operation, irrespective of the link partner's
       advertised capabilities.

APPLICATION PROGRAMMING INTERFACE
       The cloning,  character-special device /dev/nge is used to  access  all
       nge devices.

       The nge driver is dependent on /kernel/misc/mac, a loadable kernel mod‐
       ule that provides the DLPI and STREAMS functionality required of a  LAN
       driver. See gld(7D) for more details on supported primitives.

       You must send an explicit DL_ATTACH_REQ message to associate the opened
       stream with a particular device (PPA). The PPA ID is interpreted as  an
       unsigned	 integer  data	type  and  indicates  the corresponding device
       instance (unit) number. The driver returns an error  (DL_ERROR_ACK)  if
       the PPA field value does not correspond to a valid device instance num‐
       ber for the system. The device is initialized on first attach  and  de-
       initialized (stopped) at last detach.

       The  values  returned  by  the  driver  in the DL_INFO_ACK primitive in
       response to the DL_INFO_REQ are as follows:

	   o	  Maximum SDU (with jumbo frame) is 9000. (ETHERMTU -  defined
		  in <sys/ethernet>.

	   o	  Minimum SDU is 0.

	   o	  DSLAP address length is 8 bytes.

	   o	  MAC type is DL_ETHER.

	   o	  SAP  length value is	-2 meaning the physical address compo‐
		  nent is followed  immediately	 by  a	2-byte	sap  component
		  within the DLSAP address.

	   o	  Broadcast  address value is Ethernet/IEEE  broadcast address
		  (FF:FF:FF:FF:FF:FF).

       Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate
       a particular Service Access Point (SAP) with the stream.

CONFIGURATION
       By default, the nge driver performs auto-negotiation to select the link
       speed and mode. Link speed and mode can be any one  of  the  following,
       (as described in the IEEE803.2 standard):

       1000 Mbps, full-duplex.

       1000 Mbps, half-duplex.

       100 Mbps, full-duplex.

       100 Mbps, half-duplex.

       10 Mbps, full-duplex.

       10 Mbps, half-duplex.

       The  auto-negotiation  protocol automatically selects speed (1000 Mbps,
       100 Mbps, or 10 Mbps) and operation mode (full-duplex  or  half-duplex)
       as  the	highest	 common	 denominator  supported by both link partners.
       Because the nge device supports all modes, the effect is to select  the
       highest throughput mode supported by the other device.

       Alternatively,  you  can	 set  the  capabilities	 advertised by the nge
       device using ndd(1M). The driver supports a number of parameters	 whose
       names  begin with adv_ (see below). Each of these parameters contains a
       boolean value that determines if the device  advertises	that  mode  of
       operation.  The	adv_pause_cap  indicates  if half/full duplex pause is
       advertised to the link partner. The adv_asym_pause_cap parameter can be
       set  to	advertise to link partner that asymmetric pause is desired. In
       addition, nge uses adv_100T4_cap to advertise its 100T4 capability. The
       adv_autoneg_cap	parameter  controls  whether  auto-negotiation is per‐
       formed. If adv_autoneg_cap is set to 0, the driver forces the  mode  of
       operation selected by the first non-zero parameter in priority order as
       listed below:

				 (highest priority/greatest throughput)
		 adv_1000fdx_cap	 1000Mbps full duplex
		 adv_100fdx_cap		 100Mpbs full duplex
		 adv_100hdx_cap		 100Mbps half duplex
		 adv_10fdx_cap		 10Mpbs full duplex
		 adv_10hdx_cap		 10Mpbs half duplex
					 (lowest priority/least throughput)

       For example, to prevent the device nge2 from advertising gigabit	 capa‐
       bilities, enter (as super-user):

	 # ndd -set /dev/nge2 adv_1000fdx_cap 0

       All  capabilities default to enabled. Note that changing any capability
       parameter causes the link to go down while the link partners  renegoti‐
       ate the link speed/duplex using the newly changed capabilities.

       You can obtain the current parameters settings using ndd -get. In addi‐
       tion, the driver exports the current state, speed, duplex setting,  and
       working	mode  of  the link via ndd parameters (which are read only and
       may not be changed). For example, to check link state of device nge0:

	 # ndd -get /dev/nge0 link_status
	 1
	 # ndd -get /dev/nge0 link_speed
	 100
	 # ndd -get /dev/nge0 link_duplex
	 2
	 # ndd -get /dev/nge0 link_rx_pause
	 1
	 # ndd -get /dev/nge0 link_tx_pause
	 1

       The output above indicates that the link is up and running  at  100Mbps
       full-duplex with its rx/tx direction pause capability. In addition, the
       driver exports its working mode by loop_mode. If it is set  to  0,  the
       loopback mode is disabled.

       Only  MCP55/CK804  chipsets accept the Maximum MTU upper to 9000 bytes.
       Use default_mtu to set in /kernel/drv/nge.conf  file,  then  reboot  to
       make  it	 available.  The  default  MTU	value is 1500. For MCP55/CK804
       chipsets, nge provides one option of minimal memory usage. Use minimal-
       memory-usage  = 1 in the /kernel/drv/nge.conf file, then reboot to make
       it available. With this option, the nge driver can reduce memory	 usage
       by two thirds. Note that setting minimal-memory-usage = 1 does not take
       effect if MTU is increased above the default value. To avoid  problems,
       do not set the minimal-memory-usage and default_mtu options together in
       the nge.conf file.

FILES
       /dev/nge			nge special character device.

       /kernel/drv/nge		32-bit ELF Kernel module (x86).

       /kernel/drv/amd64/nge	64-bit ELF Kernel module (x86).

       /kernel/drv/nge.conf	Driver configuration file.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌───────────────────────────────────────────────────────────┐
       │ATTRIBUTE TYPE		      ATTRIBUTE VALUE		   │
       │Architecture		      x86			   │
       └───────────────────────────────────────────────────────────┘

SEE ALSO
       dladm(1M), ndd(1M), attributes(5), gld(7D), streamio(7I), dlpi(7P)

       Writing Device Drivers

       STREAMS Programming Guide

       Network Interfaces Programmer's Guide

 SunOS 5.10			  23 Apr 2010			       nge(7D)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net