net_getifname man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

net_getifname(9F)	 Kernel Functions for Drivers	     net_getifname(9F)

NAME
       net_getifname - determine the name given to a network interface

SYNOPSIS
       #include <sys/neti.h>

       int net_getifname(const net_data_t net, const phy_if_t ifp,
	    char *buffer, size_t buflen);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net	 value	 returned   from   a  successful  call	to  net_proto‐
		 col_lookup(9F).

       ifp	 value returned from a successful call to net_phylookup(9F) or
		 net_phygetnext(9F).

       buffer	 pointer to the buffer in which to write the interface name.

       buflen	 size of the buffer in which to store the interface name.

DESCRIPTION
       The  net_getifname()  function copies the name of the network interface
       into the buffer provided. The name will always be  null-terminated.  If
       the  buffer  is	too small to fit both the interface name and the null-
       terminated name, the name in  the  buffer  is  truncated	 to  fit.  See
       net_phygetnext(9F) for an example on how to use this function.

RETURN VALUES
       The net_getifname() function returns:

       -1    The network protocol does not support this function.

       0     Successful completion.

       1     Unsuccessful.

CONTEXT
       The  net_getifname()  function  may  be	called	from user,  kernel, or
       interrupt context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability		     │SUNWcsu			   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Committed			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F)

SunOS 5.10			  1 May 2008		     net_getifname(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net