mac_lso_get man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

mac_lso_get(9F)		 Kernel Functions for Drivers	       mac_lso_get(9F)

NAME
       mac_lso_get - LSO routine

SYNOPSIS
       #include <sys/mac_provider.h>

       void mac_lso_get(mblk_t *mp, uint32_t *mss, uint32_t *flags);

DESCRIPTION
       LSO  (Large  Segment Offload, or Large Send Offload) allows the network
       stack to send larger buffers to a device driver.	 These	large  buffers
       can  then  segmented in hardware, allowing for reduced CPU utilization,
       PCI overhead, and reduced buffer management costs.

       LSO is enabled only for device driver instances that advertise  support
       for  the	 MAC_CAPAB_LSO	capability  through  the mc_getcapab(9E) entry
       point.

       Once a device driver advertises the LSO capability,  it	must  use  the
       mac_lso_get() entry point to query whether LSO must be performed on the
       packet. The following values for the flags argument are supported:

       HW_LSO	 When set, this flag indicates that LSO is  enabled  for  that
		 packet. The maximum segment size (MSS) to be used during seg‐
		 mentation of the large segment is returned through the	 loca‐
		 tion pointed to by mss.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability		     │SUNWhea			   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Committed			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       attributes(5), mac(9E)

SunOS 5.10			  26 Mar 2010		       mac_lso_get(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net