VFS_STATFS(9) BSD Kernel Developer's Manual VFS_STATFS(9)NAMEVFS_STATFS — return file system status
SYNOPSIS
#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>
int
VFS_STATFS(struct mount *mp, struct statfs *sbp);
DESCRIPTION
The VFS_STATFS() macro returns various pieces of information about the
file system, including recommended I/O sizes, free space, free inodes,
etc.
The arguments it expects are:
mp The file system.
sbp A statfs structure, as defined by <sys/mount.h>, into which informa‐
tion is placed about the file system.
The fields of struct statfs related to the file system are as follows:
f_type Type of file system.
f_flags A copy of mount exported flags.
f_bsize Fragment size.
f_iosize Optimal transfer block size.
f_blocks The total number of data blocks in the file system.
f_bfree The number of free blocks in the file system.
f_bavail The number of free blocks available to non-superuser pro‐
cesses.
f_files The total number of file nodes in the file system.
f_ffree The number of free nodes available to non-superuser pro‐
cesses.
f_syncwrites The number of synchronous writes since the file system was
mounted.
f_asyncwrites The number of asynchronous writes since the file system
was mounted.
f_syncreads The number of synchronous reads since the file system was
mounted.
f_asyncreads The number of asynchronous reads since the file system was
mounted.
f_namemax The maximum file name length for this file system.
f_owner The user ID of the user that mounted the file system.
f_fsid Unique file system ID.
f_fstypename The file system type name; a string of at most MFSNAMELEN
bytes.
f_mntfromname The device name the file system was mounted from; a string
of at most MNAMELEN bytes.
f_mntonname The name of the directory on which the file system is
mounted; a string of at most MNAMELEN bytes.
SEE ALSOVFS(9), vnode(9)AUTHORS
This manual page was written by Doug Rabson.
BSD May 23, 2009 BSD