PFIL(9) | Kernel Developer's Manual | PFIL(9) |
int
pfil_head_register(struct pfil_head *ph);
int
pfil_head_unregister(struct pfil_head *ph);
struct pfil_head *
pfil_head_get(int af, u_long dlt);
struct packet_filter_hook *
pfil_hook_get(int dir, struct pfil_head *ph);
int
pfil_add_hook(int (*func)(), void *arg, int flags, struct pfil_head *ph);
int
pfil_remove_hook(int (*func)(), void *arg, int flags, struct pfil_head *ph);
int
(*func)(void *arg, struct mbuf **mp, struct ifnet *, int dir);
int
pfil_run_hooks(struct pfil_head *ph, struct mbuf **mp, struct ifnet *ifp, int dir);
Packet filtering points are registered with pfil_head_register(). Filtering points are identified by a key (void *) and a data link type (int) in the pfil_head structure. Packet filters use the key and data link type to look up the filtering point with which they register themselves. The key is unique to the filtering point. The data link type is a bpf(4) DLT constant indicating what kind of header is present on the packet at the filtering point. Filtering points may be unregistered with the pfil_head_unregister() function.
Packet filters register/unregister themselves with a filtering point with the pfil_add_hook() and pfil_remove_hook() functions, respectively. The head is looked up using the pfil_head_get() function, which takes the key and data link type that the packet filter expects. Filters may provide an argument to be passed to the filter when invoked on a packet.
When a filter is invoked, the packet appears just as if it “came off the wire”. That is, all protocol fields are in network byte order. The filter is called with its specified argument, the pointer to the pointer to the mbuf containing the packet, the pointer to the network interface that the packet is traversing, and the direction (PFIL_IN or PFIL_OUT, see also below) that the packet is traveling. The filter may change which mbuf the mbuf ** argument references. The filter returns an errno if the packet processing is to stop, or 0 if the processing is to continue. If the packet processing is to stop, it is the responsibility of the filter to free the packet.
The flags parameter, used in the pfil_add_hook() and pfil_remove_hook() functions, indicates when the filter should be called. The flags are:
The pfil interface is enabled in the kernel via the PFIL_HOOKS option.
The pfil interface was changed in 1.4T to accept a 3rd parameter to both pfil_add_hook() and pfil_remove_hook(), introducing the capability of per-protocol filtering. This was done primarily in order to support filtering of IPv6.
In 1.5K, the pfil framework was changed to work with an arbitrary number of filtering points, as well as be less IP-centric.
January 8, 2006 | NetBSD 6.1 |