IEEE80211_INPUT(9) | Kernel Developer's Manual | IEEE80211_INPUT(9) |
void
ieee80211_input(struct ieee80211com *ic, struct mbuf *m, struct ieee80211_node *ni, int rssi, u_int32_t rstamp);
struct mbuf *
ieee80211_decap(struct ieee80211com *ic, struct mbuf *m);
void
ieee80211_recv_mgmt(struct ieee80211com *ic, struct mbuf *m0, struct ieee80211_node *ni, int subtype, int rssi, u_int32_t rstamp);
The ieee80211_input() function takes an mbuf chain m containing a complete 802.11 frame from the driver ic and passes it to the software 802.11 stack for input processing. The ni argument specifies an instance of struct ieee80211_node (which may be driver-specific) representing the node from which the frame was received. The arguments rssi and stamp are typically derived from on-card data structures; they are used for recording the signal strength and time received of the frame respectively.
The ieee80211_decap() function performs decapsulation of the 802.11 frame in the mbuf chain m received by the device ic, taking the form of the 802.11 address fields into account; the structure of 802.11 addresses vary according to the intended source and destination of the frame. It is typically called from within ieee80211_input().
The ieee80211_recv_mgmt() performs input processing for 802.11 management frames. It is typically called from within ieee80211_input().
September 12, 2006 | NetBSD 6.1 |