USB(4) | Kernel Interfaces Manual | USB(4) |
options USBVERBOSE
#include <dev/usb/usb.h>
#include <dev/usb/usbhid.h>
The NetBSD usb driver has three layers (like scsi(4) and pcmcia(4)): the controller, the bus, and the device layer. The controller attaches to a physical bus (like pci(4)). The USB bus attaches to the controller and the root hub attaches to the bus. Further devices, which may include further hubs, attach to other hubs. The attachment forms the same tree structure as the physical USB device tree. For each USB device there may be additional drivers attached to it.
The uhub device controls USB hubs and must always be present since there is at least a root hub in any USB system.
The flags argument to the usb device affects the order in which the device detection happens during cold boot. Normally, only the USB host controller and the usb device are detected during the autoconfiguration when the machine is booted. The rest of the devices are detected once the system becomes functional and the kernel thread for the usb device is started. Sometimes it is desirable to have a device detected early in the boot process, e.g., the console keyboard. To achieve this use a flags value of 1.
NetBSD supports the following machine-independent USB drivers:
There can be up to 127 devices (apart from the host controller) on a bus, each with its own address. The addresses are assigned dynamically by the host when each device is attached to the bus.
Within each device there can be up to 16 endpoints. Each endpoint is individually addressed and the addresses are static. Each of these endpoints will communicate in one of four different modes: control, isochronous, bulk, or interrupt. A device always has at least one endpoint. This endpoint has address 0 and is a control endpoint and is used to give commands to and extract basic data, such as descriptors, from the device. Each endpoint, except the control endpoint, is unidirectional.
The endpoints in a device are grouped into interfaces. An interface is a logical unit within a device; e.g., a compound device with both a keyboard and a trackball would present one interface for each. An interface can sometimes be set into different modes, called alternate settings, which affects how it operates. Different alternate settings can have different endpoints within it.
A device may operate in different configurations. Depending on the configuration the device may present different sets of endpoints and interfaces.
Each device located on a hub has several config(1) locators:
The bus enumeration of the USB bus proceeds in several steps:
#include <dev/usb/usb.h>
The /dev/usbN can be opened and a few operations can be performed on it. The poll(2) system call will say that I/O is possible on the controller device when a USB device has been connected or disconnected to the bus.
The following ioctl(2) commands are supported on the controller device:
struct usb_device_info { uint8_t udi_bus; uint8_t udi_addr; usb_event_cookie_t udi_cookie; char udi_product[USB_MAX_ENCODED_STRING_LEN]; char udi_vendor[USB_MAX_ENCODED_STRING_LEN]; char udi_release[8]; char udi_serial[USB_MAX_ENCODED_STRING_LEN]; uint16_t udi_productNo; uint16_t udi_vendorNo; uint16_t udi_releaseNo; uint8_t udi_class; uint8_t udi_subclass; uint8_t udi_protocol; uint8_t udi_config; uint8_t udi_speed; #define USB_SPEED_LOW 1 #define USB_SPEED_FULL 2 #define USB_SPEED_HIGH 3 int udi_power; int udi_nports; char udi_devnames[USB_MAX_DEVNAMES][USB_MAX_DEVNAMELEN]; uint8_t udi_ports[16]; #define USB_PORT_ENABLED 0xff #define USB_PORT_SUSPENDED 0xfe #define USB_PORT_POWERED 0xfd #define USB_PORT_DISABLED 0xfc };
The product, vendor, release, and serial fields contain self-explanatory descriptions of the device.
The class field contains the device class.
The config field shows the current configuration of the device.
The lowspeed field is set if the device is a USB low speed device.
The power field shows the power consumption in milli-amps drawn at 5 volts, or zero if the device is self powered.
If the device is a hub the nports field is non-zero and the ports field contains the addresses of the connected devices. If no device is connected to a port one of the USB_PORT_* values indicates its status.
struct usb_device_stats { u_long uds_requests[4]; };
The requests field is indexed by the transfer kind, i.e. UE_*, and indicates how many transfers of each kind have been completed by the controller.
The include file <dev/usb/usb.h> contains definitions for the types used by the various ioctl(2) calls. The naming convention of the fields for the various USB descriptors exactly follows the naming in the USB specification. Byte sized fields can be accessed directly, but word (16 bit) sized fields must be access by the UGETW(field) and USETW(field, value) macros to handle byte order and alignment properly.
The include file <dev/usb/usbhid.h> similarly contains the definitions for Human Interface Devices (HID).
The event record has the following definition:
struct usb_event { int ue_type; #define USB_EVENT_CTRLR_ATTACH 1 #define USB_EVENT_CTRLR_DETACH 2 #define USB_EVENT_DEVICE_ATTACH 3 #define USB_EVENT_DEVICE_DETACH 4 #define USB_EVENT_DRIVER_ATTACH 5 #define USB_EVENT_DRIVER_DETACH 6 struct timespec ue_time; union { struct { int ue_bus; } ue_ctrlr; struct usb_device_info ue_device; struct { usb_event_cookie_t ue_cookie; char ue_devname[16]; } ue_driver; } u; };
The ue_type field identifies the type of event that is described. The possible events are attach/detach of a host controller, a device, or a device driver. The union contains information pertinent to the different types of events.
The ue_bus contains the number of the USB bus for host controller events.
The ue_device record contains information about the device in a device event event.
The ue_cookie is an opaque value that uniquely determines which device a device driver has been attached to (i.e., it equals the cookie value in the device that the driver attached to). The ue_devname contains the name of the device (driver) as seen in, e.g., kernel messages.
Note that there is a separation between device and device driver events. A device event is generated when a physical USB device is attached or detached. A single USB device may have zero, one, or many device drivers associated with it.
In addition there is a kernel thread, usbtask, which handles various minor tasks that are initiated from an interrupt context, but need to sleep, e.g., time-out abort of transfers.
Universal Serial Bus Specifications Documents, http://www.usb.org/developers/docs/.
January 22, 2012 | NetBSD 6.1 |