MK48TXX(4) | Kernel Interfaces Manual | MK48TXX(4) |
define mk48txx
file dev/ic/mk48txx.c mk48txx
To tie an instance of this device to the system, use the mk48txx_attach() function and the mk48txx_softc structure defined as follows:
void mk48txx_attach(struct mk48txx_softc *)
typedef uint8_t (*mk48txx_nvrd_t)(struct mk48txx_softc *, int off); typedef void (*mk48txx_nvwr_t)(struct mk48txx_softc *, int off, uint8_t datum);
struct mk48txx_softc { struct device sc_dev; bus_space_tag_t sc_bst; bus_space_handle_t sc_bsh; struct todr_chip_handle sc_handle; const char *sc_model; bus_size_t sc_nvramsz; bus_size_t sc_clkoffset; u_int sc_year0; u_int sc_flag; mk48txx_nvrd_t sc_nvrd; mk48txx_nvwr_t sc_nvwr; };
Otherwise, the driver will call the respective function to perform the access, passing it the specified bus space and the offset off of the chip memory (or clock register) location to be read from or written to, respectively.
Note that if the resulting date retrieved with the todr_gettime() method is earlier that January 1, 1970, the driver will assume that the chip's year counter actually represents a year in the 21st century. This behaviour can be overridden by setting the MK48TXX_NO_CENT_ADJUST flag in sc_flag.
October 1, 2006 | NetBSD 6.1 |