vgrindefs man page on BSDOS

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDOS logo
[printable version]

VGRINDEFS(5)		    BSD Programmer's Manual		  VGRINDEFS(5)

NAME
     vgrindefs - language definition data base for vgrind(1)

SYNOPSIS
     vgrindefs

DESCRIPTION
     The vgrindefs file contains all language definitions for vgrind(1).  The
     data base is very similar to termcap(5).

FIELDS
     The following table names and describes each field.

     Name	Type	  Description
     pb		str	  regular expression for start of a procedure
     bb		str	  regular expression for start of a lexical block
     be		str	  regular expression for the end of a lexical block
     cb		str	  regular expression for the start of a comment
     ce		str	  regular expression for the end of a comment
     ab		str	  alternate regular expression for the start of a
			  comment
     ae		str	  alternate regular expression for the end of a
			  comment
     sb		str	  regular expression for the start of a string
     se		str	  regular expression for the end of a string
     lb		str	  regular expression for the start of a character
			  constant
     le		str	  regular expression for the end of a character
			  constant
     tl		bool	  present means procedures are only defined at the top
			  lexical level
     oc		bool	  present means upper and lower case are equivalent
     kw		str	  a list of keywords separated by spaces

EXAMPLES
     The following entry, which describes the C language, is typical of a lan-
     guage entry.

     C|c:\
     :pb=^\d?*?\d?\p\d?\(\a?\)(\d|{):bb={:be=}:cb=/*:ce=*/:sb=":se=\e":lb=':\
     :le=\e':tl:\
     :kw=asm auto break case char continue default do double else enum\
     extern float for fortran goto if int long register return short\
     sizeof static struct switch typedef union unsigned void while\
     volatile const #define\
     #else #endif #if #elif #ifdef #ifndef #include #undef # define endif\
     elif ifdef ifndef include undef defined:

     Note that the first field is just the language name (and any variants of
     it).  Thus the C language could be specified to vgrind(1) as "c" or "C".

     Entries may continue onto multiple lines by giving a \ as the last char-
     acter of a line.  Capabilities in vgrindefs are of two types: Boolean ca-
     pabilities which indicate that the language has some particular feature
     and string capabilities which give a regular expression or keyword list.

REGULAR EXPRESSIONS
     Vgrindefs uses regular expression which are very similar to those of
     ex(1) and lex(1).	The characters `^', `$', `:' and `\' are reserved
     characters and must be "quoted" with a preceding `\' if they are to be
     included as normal characters.  The metasymbols and their meanings are:

     $	     the end of a line

     ^	     the beginning of a line

     \d	     a delimiter (space, tab, newline, start of line)

     \a	     matches any string of symbols (like .* in lex)

     \p	     matches any alphanumeric name.  In a procedure definition (pb)
	     the string that matches this symbol is used as the procedure
	     name.

     ()	     grouping

     |	     alternation

     ?	     last item is optional

     \e	     preceding any string means that the string will not match an in-
	     put string if the input string is preceded by an escape character
	     (\).  This is typically used for languages (like C) which can in-
	     clude the string delimiter in a string by escaping it.

     Unlike other regular expressions in the system,  these match words and
     not characters.  Hence something like "(tramp|steamer)flies?"  would
     match "tramp", "steamer", "trampflies", or "steamerflies".

     Note that the regular expressions will return the first match.  When
     specifying a word that is a prefix or suffix of another word, the longer
     word should be listed first.  For example, given a language with the key-
     words "for" and "foreach", "foreach" should be listed first.

KEYWORD LIST
     The keyword list is just a list of keywords in the language separated by
     spaces.  If the "oc" boolean is specified, indicating that upper and low-
     er case are equivalent, then all the keywords should be specified in low-
     er case.

FILES
     /usr/share/misc/vgrindefs	File containing terminal descriptions.

SEE ALSO
     vgrind(1),	 troff(1)

HISTORY
     The vgrindefs file format appeared in 4.2BSD.

4.2 Berkeley Distribution	 June 6, 1993				     2
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server BSDOS

List of man pages available for BSDOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net