uma_zcreate man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

ZONE(9)			 BSD Kernel Developer's Manual		       ZONE(9)

NAME
     uma_zcreate, uma_zalloc, uma_zalloc_arg, uma_zfree, uma_zfree_arg,
     uma_zdestroy, uma_zone_set_max, uma_zone_get_max, uma_zone_get_cur — zone
     allocator

SYNOPSIS
     #include <sys/param.h>
     #include <sys/queue.h>
     #include <vm/uma.h>

     uma_zone_t
     uma_zcreate(char *name, int size, uma_ctor ctor, uma_dtor dtor,
	 uma_init uminit, uma_fini fini, int align, u_int16_t flags);

     void *
     uma_zalloc(uma_zone_t zone, int flags);

     void *
     uma_zalloc_arg(uma_zone_t zone, void *arg, int flags);

     void
     uma_zfree(uma_zone_t zone, void *item);

     void
     uma_zfree_arg(uma_zone_t zone, void *item, void *arg);

     void
     uma_zdestroy(uma_zone_t zone);

     void
     uma_zone_set_max(uma_zone_t zone, int nitems);

     int
     uma_zone_get_max(uma_zone_t zone);

     int
     uma_zone_get_cur(uma_zone_t zone);

DESCRIPTION
     The zone allocator provides an efficient interface for managing dynami‐
     cally-sized collections of items of similar size.	The zone allocator can
     work with preallocated zones as well as with runtime-allocated ones, and
     is therefore available much earlier in the boot process than other memory
     management routines.

     A zone is an extensible collection of items of identical size.  The zone
     allocator keeps track of which items are in use and which are not, and
     provides functions for allocating items from the zone and for releasing
     them back (which makes them available for later use).

     After the first allocation of an item, it will have been cleared to
     zeroes, however subsequent allocations will retain the contents as of the
     last free.

     The uma_zcreate() function creates a new zone from which items may then
     be allocated from.	 The name argument is a text name of the zone for
     debugging and stats; this memory should not be freed until the zone has
     been deallocated.

     The ctor and dtor arguments are callback functions that are called by the
     uma subsystem at the time of the call to uma_zalloc() and uma_zfree()
     respectively.  Their purpose is to provide hooks for initializing or
     destroying things that need to be done at the time of the allocation or
     release of a resource.  A good usage for the ctor and dtor callbacks
     might be to adjust a global count of the number of objects allocated.

     The uminit and fini arguments are used to optimize the allocation of
     objects from the zone.  They are called by the uma subsystem whenever it
     needs to allocate or free several items to satisfy requests or memory
     pressure.	A good use for the uminit and fini callbacks might be to ini‐
     tialize and destroy mutexes contained within the object.  This would
     allow one to re-use already initialized mutexes when an object is
     returned from the uma subsystem's object cache.  They are not called on
     each call to uma_zalloc() and uma_zfree() but rather in a batch mode on
     several objects.

     To allocate an item from a zone, simply call uma_zalloc() with a pointer
     to that zone and set the flags argument to selected flags as documented
     in malloc(9).  It will return a pointer to an item if successful, or NULL
     in the rare case where all items in the zone are in use and the allocator
     is unable to grow the zone or when M_NOWAIT is specified.

     Items are released back to the zone from which they were allocated by
     calling uma_zfree() with a pointer to the zone and a pointer to the item.
     If item is NULL, then uma_zfree() does nothing.

     The variations uma_zalloc_arg() and uma_zfree_arg() allow to specify an
     argument for the ctor and dtor functions, respectively.

     Created zones, which are empty, can be destroyed using uma_zdestroy(),
     freeing all memory that was allocated for the zone.  All items allocated
     from the zone with uma_zalloc() must have been freed with uma_zfree()
     before.

     The uma_zone_set_max() function limits the number of items (and therefore
     memory) that can be allocated to zone.  The nitems argument specifies the
     requested upper limit number of items.  The effective limit may end up
     being higher than requested, as the implementation will round up to
     ensure all memory pages allocated to the zone are utilised to capacity.
     The limit applies to the total number of items in the zone, which
     includes allocated items, free items and free items in the per-cpu
     caches.  On systems with more than one CPU it may not be possible to
     allocate the specified number of items even when there is no shortage of
     memory, because all of the remaining free items may be in the caches of
     the other CPUs when the limit is hit.

     The uma_zone_get_max() function returns the effective upper limit number
     of items for a zone.

     The uma_zone_get_cur() function returns the approximate current occupancy
     of the zone.  The returned value is approximate because appropriate syn‐
     chronisation to determine an exact value is not performend by the imple‐
     mentation.	 This ensures low overhead at the expense of potentially stale
     data being used in the calculation.

RETURN VALUES
     The uma_zalloc() function returns a pointer to an item, or NULL if the
     zone ran out of unused items and the allocator was unable to enlarge it.

SEE ALSO
     malloc(9)

HISTORY
     The zone allocator first appeared in FreeBSD 3.0.	It was radically
     changed in FreeBSD 5.0 to function as a slab allocator.

AUTHORS
     The zone allocator was written by John S. Dyson.  The zone allocator was
     rewritten in large parts by Jeff Roberson ⟨jeff@FreeBSD.org⟩ to function
     as a slab allocator.

     This manual page was written by Dag-Erling Smørgrav ⟨des@FreeBSD.org⟩.
     Changes for UMA by Jeroen Ruigrok van der Werven ⟨asmodai@FreeBSD.org⟩.

BSD				October 9, 2010				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net