thread_exit man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

THREAD_EXIT(9)		 BSD Kernel Developer's Manual		THREAD_EXIT(9)

NAME
     thread_exit — abandon current thread context

SYNOPSIS
     #include <sys/param.h>
     #include <sys/proc.h>

     void
     thread_exit(void);

DESCRIPTION
     The thread_exit() function implements the machine independent prelude to
     a thread shutdown.	 It will not return, and will result in a call to
     mi_switch(9) to schedule some other thread.

     thread_exit() arranges to free all the resources of the thread, specifi‐
     cally the kernel stack.

     To protect the runqueue(9), thread_exit() must be called with the
     sched_lock mutex held.

SEE ALSO
     mi_switch(9), mutex(9), runqueue(9), sleep(9)

BSD				 July 5, 2002				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net