pmap_wired_count man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

PMAP_RESIDENT_COUNT(9)	 BSD Kernel Developer's Manual	PMAP_RESIDENT_COUNT(9)

NAME
     pmap_resident_count, pmap_wired_count — return page resident and wiring
     statistics

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/pmap.h>

     long
     pmap_resident_count(pmap_t pmap);

     long
     pmap_wired_count(pmap_t pmap);

DESCRIPTION
     The pmap_resident_count() and pmap_wired_count() macros allow pmap con‐
     sumers to retrieve statistics from the pm_stats member of the machine-
     dependent structure struct pmap.

IMPLEMENTATION NOTES
     Both functions are defined as in-line macros.  The members which they
     access have type long.

RETURN VALUES
     The pmap_resident_count() returns the number of pages in the physical map
     pmap which are currently resident in main memory.

     The pmap_wired_count() returns the number of pages in the physical map
     pmap which are currently wired into in main memory.

SEE ALSO
     pmap(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 21, 2003				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net