operator man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

OPERATOR(7)	     BSD Miscellaneous Information Manual	   OPERATOR(7)

NAME
     operator — C and C++ operator precedence and order of evaluation

DESCRIPTION
	   Operator				       Associativity
	   --------				       -------------
	   () [] -> .				       left to right
	   ! ~ ++ -- - (type) * & sizeof new delete    right to left
	   ->* .*				       left to right
	   * / %				       left to right
	   + -					       left to right
	   << >>				       left to right
	   < <= > >=				       left to right
	   == !=				       left to right
	   &					       left to right
	   ^					       left to right
	   |					       left to right
	   &&					       left to right
	   ||					       left to right
	   ?:					       right to left
	   = += -= *= /= %= <<= >>= &= ^= |= throw     right to left
	   ?: (C++, third operand)		       right to left
	   ,					       left to right

FILES
     /usr/share/misc/operator

BSD				 April 8, 2009				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net