netintro man page on BSDOS

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDOS logo
[printable version]

NETINTRO(4)		    BSD Programmer's Manual		   NETINTRO(4)

NAME
     networking - introduction to networking facilities

SYNOPSIS
     #include <sys/socket.h>
     #include <net/route.h>
     #include <net/if.h>

DESCRIPTION
     This section is a general introduction to the networking facilities
     available in the system.  Documentation in this part of section 4 is bro-
     ken up into three areas: protocol families (domains), protocols, and
     network interfaces.

     All network protocols are associated with a specific protocol family. A
     protocol family provides basic services to the protocol implementation to
     allow it to function within a specific network environment.  These ser-
     vices may include packet fragmentation and reassembly, routing, address-
     ing, and basic transport.	A protocol family may support multiple methods
     of addressing, though the current protocol implementations do not.	 A
     protocol family is normally composed of a number of protocols, one per
     socket(2) type.  It is not required that a protocol family support all
     socket types.  A protocol family may contain multiple protocols support-
     ing the same socket abstraction.

     A protocol supports one of the socket abstractions detailed in socket(2).
      A specific protocol may be accessed either by creating a socket of the
     appropriate type and protocol family, or by requesting the protocol ex-
     plicitly when creating a socket.  Protocols normally accept only one type
     of address format, usually determined by the addressing structure inher-
     ent in the design of the protocol family/network architecture.  Certain
     semantics of the basic socket abstractions are protocol specific.	All
     protocols are expected to support the basic model for their particular
     socket type, but may, in addition, provide non-standard facilities or ex-
     tensions to a mechanism.  For example, a protocol supporting the
     SOCK_STREAM abstraction may allow more than one byte of out-of-band data
     to be transmitted per out-of-band message.

     A network interface is similar to a device interface.  Network interfaces
     comprise the lowest layer of the networking subsystem, interacting with
     the actual transport hardware.  An interface may support one or more pro-
     tocol families and/or address formats.  The SYNOPSIS section of each net-
     work interface entry gives a sample specification of the related drivers
     for use in providing a system description to the config(8) program.  The
     DIAGNOSTICS section lists messages which may appear on the console and/or
     in the system error log (see syslog.conf(5) and syslog(8)) due to errors
     in device operation.

PROTOCOLS
     The system currently supports the Internet protocols, the Xerox Network
     Systems(tm) protocols, and some of the ISO OSI protocols.	Raw socket in-
     terfaces are provided to the IP protocol layer of the Internet, and to
     the IDP protocol of Xerox NS. Consult the appropriate manual pages in
     this section for more information regarding the support for each protocol
     family.

ADDRESSING
     Associated with each protocol family is an address format.	 All network
     address adhere to a general structure, called a sockaddr, described be-
     low. However, each protocol imposes finer and more specific structure,
     generally renaming the variant, which is discussed in the protocol family
     manual page alluded to above.

	   struct sockaddr {
	       u_char	   sa_len;
	       u_char	   sa_family;
	       char	   sa_data[14];
	   };

     The field sa_len contains the total length of the of the structure, which
     may exceed 16 bytes.  The following address values for sa_family are
     known to the system.  Additional formats are defined for possible future
     implementation:

     #define	AF_LOCAL     1	  /* local to host (pipes, portals) */
     #define	AF_INET	     2	  /* internetwork: UDP, TCP, etc. */
     #define	AF_NS	     6	  /* Xerox NS protocols */
     #define	AF_CCITT     10	  /* CCITT protocols, X.25 etc */
     #define	AF_HYLINK    15	  /* NSC Hyperchannel */
     #define	AF_ISO	     18	  /* ISO protocols */

ROUTING
     The operating system provides packet forwarding facilities by maintaining
     a ``forwarding information database'', or ``forwarding table''. This
     database is used in selecting the appropriate network interface when
     transmitting packets.

     One or more co-operating user processes (see gated(8)and routed(8))
     maintain this database by sending messages over a special type of socket,
     the ``routing socket'' as described in route(4).  This supplants the
     fixed size ioctl(2) calls (SIOCADDRT and SIOCDELRT) used in earlier re-
     leases.

     The term ``routing'' technically refers to the use of routing protocols
     to discover ``routes'' to remote networks and hosts.  The term
     ``forwarding'' refers to the process of sending a packet on towards its
     eventual destination.  An entry in the operating system's forwarding
     table can be referred to as a ``forwarding table entry'' or a ``route''.

INTERFACES
     Each network interface in a system corresponds to a path through which
     messages may be sent and received.	 A network interface usually has a
     hardware device associated with it, though certain interfaces such as the
     loopback interface, lo(4),	 do not.

     The following ioctl(2) calls may be used to manipulate network inter-
     faces. The ioctl(2) is made on a socket (typically of type SOCK_DGRAM) in
     the desired domain.  Descriptions of the ioctl(2) calls are grouped by
     the structure used as an argument.	 All the listed ioctl(2) calls identi-
     fy interfaces by name (e.g. ``ef0'').

   struct ifreq

     The struct ifreq is used to identify an interface by name (e.g. ``we0'')
     and pass one attribute of the configuration of an interface.  The layout
     of the struct ifreq is:

     struct  ifreq {
     #define	IFNAMSIZ    16
	 char	 ifr_name[IFNAMSIZ];	    /* if name, e.g. "we0" */
	 union {
	     struct    sockaddr ifru_addr;
	     struct    sockaddr ifru_dstaddr;
	     struct    sockaddr ifru_broadaddr;
	     short     ifru_flags;
	     int       ifru_metric;
	     caddr_t   ifru_data;
	 } ifr_ifru;
     #define ifr_addr	   ifr_ifru.ifru_addr	 /* address */
     #define ifr_dstaddr   ifr_ifru.ifru_dstaddr /* other end of p-to-p link */
     #define ifr_broadaddr ifr_ifru.ifru_broadaddr /* broadcast address */
     #define ifr_flags	   ifr_ifru.ifru_flags	 /* flags */
     #define ifr_metric	   ifr_ifru.ifru_metric	 /* metric */
     #define ifr_mtu	   ifr_ifru.ifru_metric	 /* MTU */
     #define ifr_data	   ifr_ifru.ifru_data	 /* for use by interface */
     };

     SIOCDIFADDR    Delete interface address.  The specified address from the
		    list associated with the interface is deleted. Specifica-
		    tion of a default address for a protocol family is inter-
		    preted to mean that the primary (first) address in this
		    protocol family for the specified interface should be
		    deleted.  Uses the ifr_addr field of the struct ifreq, or
		    a protocol family specific structure.

     SIOCGIFFLAGS   Get interface flags.  Uses the ifr_flags field of the
		    struct ifreq.

     SIOCSIFFLAGS   Set interface flags field.	If the interface is marked
		    down, any processes currently routing packets through the
		    interface are notified; some interfaces may be reset so
		    that incoming packets are no longer received.  When marked
		    up again, the interface is reinitialized.  Uses the
		    ifr_flags field of the struct ifreq.

     SIOCGIFMETRIC  Get interface metric.  Uses the ifr_metric field of the
		    struct ifreq.

     SIOCSIFMETRIC  Set interface routing metric.  The metric is used only by
		    user-level routers.	 Uses the ifr_metric field of the
		    struct ifreq.

     SIOCSIFADDR    Set interface address.  The use of SIOCSIFADDR is depre-
		    cated for all address families except AF_LINK where it is
		    used to set the interface type using a sockaddr_dl struc-
		    ture as defined in <net/if_dl.h> Uses the ifr_addr field
		    of the struct ifreq.

     SIOCGIFMTU	    Get the interface MTU.  Uses the ifr_mtu field of the
		    struct ifreq.

     SIOCSIFMTU	    Set the interface MTU.  Uses the ifr_mtu field of the
		    struct ifreq. Not all interfaces support SIOCSIFMTU.

     The following calls use the ifreq structure, but are deprecated.  They
     are not capable of distinguishing multiple addresses in the same protocol
     assigned to a given interface.  Their functionality is provided by the
     sysctl(3) and getifaddrs(3) subroutines.

     SIOCGIFADDR     Get interface address for protocol family.	 Uses the
		     ifr_addr field of the struct ifreq.

     SIOCGIFBRDADDR  Get broadcast address for protocol family and interface.
		     Uses the ifr_broadaddr field of the struct ifreq.

     SIOCGIFDSTADDR  Get point to point destination address for protocol fami-
		     ly and interface.	Uses the ifr_dstaddr field of the
		     struct ifreq.

     SIOCGIFNETMASK  Get the network mask for the specified interface.	Uses
		     the ifr_addr field of the struct ifreq.

     The following calls use the ifreq structure, but are deprecated.  They
     are not capable of distinguishing multiple addresses in the same protocol
     assigned to a given interface.  Their functionality is provided by the

     SIOCAIFADDR and SIOCDIFADDR ioctl(2) system calls.

     SIOCSIFBRDADDR  Set broadcast address for protocol family and interface.
		     Uses the ifr_broadaddr field of the struct ifreq.

     SIOCSIFDSTADDR  Set point to point destination address for protocol fami-
		     ly and interface.	Uses the ifr_dstaddr field of the
		     struct ifreq.

     SIOCGIFNETMASK  Set the network mask for the specified interface.	Uses
		     the ifr_addr field of the struct ifreq.

   struct ifaliasreq

     The ifaliasreq structure is a model of the structure used to set the ad-
     dress configuration of an interface.  The actual structure used will con-
     tain sockaddr structures appropriate to the protocol family being config-
     ured.  Address families with sockaddr structures smaller or larger than
     the default will have alternate version of the ioctl(2) identifier encod-
     ed with different lengths (e.g. SIOCAIFADDR_ISO).

     struct ifaliasreq {
	     char    ifra_name[IFNAMSIZ];   /* if name, e.g. "en0" */
	     struct  sockaddr	     ifra_addr;
	     struct  sockaddr	     ifra_broadaddr;
	     struct  sockaddr	     ifra_mask;
     };

     The ioctl(2) call that makes use of this structure is:

     SIOCAIFADDR  Add or change the address of an interface.  Protocol fami-
		  lies that support multiple protocol addresses per interface
		  allow an additional addresses (referred to as ``aliases'')
		  to be assigned to and interface when the specified address
		  does not match an existing address assigned to the inter-
		  face.	 When the specified address matches an existing ad-
		  dress the characteristics of that address are changed.  If
		  the default address for the protocol family is specified,
		  the characteristics of the primary address are changed.

   struct ifconf

     struct ifconf {
	 int   ifc_len;		     /* size of associated buffer */
	 union {
	     caddr_t	ifcu_buf;
	     struct	ifreq *ifcu_req;
	 } ifc_ifcu;
     #define ifc_buf ifc_ifcu.ifcu_buf /* buffer address */
     #define ifc_req ifc_ifcu.ifcu_req /* array of structures returned */
     };

     The following call uses the struct ifconf.

     SIOCGIFCONF  This interface is deprecated, the interface list is avail-
		  able via sysctl(3) and getifaddrs(3).

		  Get interface configuration list.  This request takes an
		  ifconf structure as a value-result parameter.	 The ifc_len
		  field should be initially set to the size of the buffer
		  pointed to by ifc_buf. On return it will contain the length,
		  in bytes, of the configuration list.	If the buffer is not
		  large enough to hold the complete interface list, the errno
		  variable will be set to EFAULT.

SEE ALSO
     socket(2),	 ioctl(2),  getifaddrs(3),  sysctl(3),	inet(4),  intro(4),
     iso(4),  localdomain(4),  ns(4),  route(4),  config(8),  gated(8),
     ifconfig(8),  routed(8)

HISTORY
     The netintro manual entry appeared in 4.3BSD-Tahoe.

4.2 Berkeley Distribution      November 30, 1993			     5
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server BSDOS

List of man pages available for BSDOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net