iic man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

IIC(4)			 BSD Kernel Interfaces Manual			IIC(4)

NAME
     iic — I2C generic I/O device driver

SYNOPSIS
     device iic

     #include <dev/iicbus/iic.h>

DESCRIPTION
     The iic device driver provides generic I/O to any iicbus(4) instance.  In
     order to control I2C devices, use /dev/iic? with the following ioctls:

     I2CSTART	  (struct iiccmd) Sends the start condition to the slave spec‐
		  ified by the slave element to the bus.  All other elements
		  are ignored.

     I2CRPTSTART  (struct iiccmd) Sends the repeated start condition to the
		  slave specified by the slave element to the bus.  All other
		  elements are ignored.

     I2CSTOP	  No argument is passed.  Sends the stop condition to the bus.
		  This terminates the current transaction.

     I2CRSTCARD	  (struct iiccmd) Resets the bus.  The argument is completely
		  ignored.

     I2CWRITE	  (struct iiccmd) Writes data to the iicbus(4).	 The bus
		  should already be started.  The slave element is ignored.
		  The count element is the number of bytes to write.  The last
		  element is a boolean flag.  It is non-zero when additional
		  write commands will follow.  The buf element is a pointer to
		  the data to write to the bus.

     I2CREAD	  (struct iiccmd) Reads data from the iicbus(4).  The bus
		  should already be started.  The slave element is ignored.
		  The count element is the number of bytes to write.  The last
		  element is a boolean flag.  It is non-zero when additional
		  write commands will follow.  The buf element is a pointer to
		  where to store the data read from the bus.  Short reads on
		  the bus produce undefined results.

     I2CRDWR	  (struct iic_rdwr_data) Generic read/write interface.	Allows
		  for an arbitrary number of commands to be sent to an arbi‐
		  trary number of devices on the bus.  A read transfer is
		  specified if IIC_M_RD is set in flags.  Otherwise the trans‐
		  fer is a write transfer.  The slave element specifies the
		  7-bit address for the transfer.  The len element is the
		  length of the data.  The buf element is a buffer for that
		  data.	 This ioctl is intended to be Linux compatible.

     The following data structures are defined in <dev/iicbus/iic.h> and ref‐
     erenced above:

	   struct iiccmd {
		   u_char slave;
		   int count;
		   int last;
		   char *buf;
	   };

	   /* Designed to be compatible with linux's struct i2c_msg */
	   struct iic_msg
	   {
		   uint16_t	   slave;
		   uint16_t	   flags;
	   #define IIC_M_RD	   0x0001  /* read vs write */
		   uint16_t	   len;	   /* msg legnth */
		   uint8_t *	   buf;
	   };

	   struct iic_rdwr_data {
		   struct iic_msg *msgs;
		   uint32_t nmsgs;
	   };

     It is also possible to use read/write routines, then I2C start/stop hand‐
     shake is managed by the iicbus(4) system.	However, the address used for
     the read/write routines is the one passed to last I2CSTART ioctl(2) to
     this device.

SEE ALSO
     ioctl(2), read(2), write(2), iicbus(4)

HISTORY
     The iic manual page first appeared in FreeBSD 3.0.

AUTHORS
     This manual page was written by Nicolas Souchu and M. Warner Losh.

BUGS
     Only the I2CRDWR ioctl(2) is thread safe.	All other interfaces suffer
     from some kind of race.

BSD			       September 6, 2006			   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net