gettytab man page on BSDOS

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDOS logo
[printable version]

GETTYTAB(5)		    BSD Programmer's Manual		   GETTYTAB(5)

NAME
     gettytab - terminal configuration data base

SYNOPSIS
     gettytab

DESCRIPTION
     The gettytab file is a simplified version of the termcap(5) data base
     used to describe terminal lines.  The initial terminal login process get-
     ty(8) accesses the gettytab file each time it starts, allowing simpler
     reconfiguration of terminal characteristics.  Each entry in the data base
     is used to describe one class of terminals.

     There is a default terminal class, default, that is used to set global
     defaults for all other classes.  (That is, the default entry is read,
     then the entry for the class required is used to override particular set-
     tings.)

CAPABILITIES
     Refer to termcap(5) for a description of the file layout.	The default
     column below lists defaults obtained if there is no entry in the table
     obtained, nor one in the special default table.

     Name    Type    Default	       Description
     ap	     bool    false	       set 7-bits and ignore input parity
     bi	     bool    false	       bidirectional line (dial-in, dial-out)
     bk	     str     0377	       alternate end of line character (input
				       break)
     ce	     bool    false	       use crt erase algorithm
     ck	     bool    false	       use crt kill algorithm
     cl	     str     NULL	       screen clear sequence
     co	     bool    false	       console - add `\n' after login prompt
     de	     num     unused	       delay before first banner
     ds	     str     `^Y'	       delayed suspend character
     dx	     bool    false	       set DECCTLQ
     ec	     bool    false	       leave echo OFF
     ep	     bool    false	       terminal uses even parity, 7-bits
     er	     str     `^?'	       erase character
     et	     str     `^D'	       end of text (EOF) character
     ev	     str     NULL	       initial environment
     fl	     str     `^O'	       output flush character
     hc	     bool    false	       do NOT hangup line on last close
     he	     str     NULL	       hostname editing string
     hf	     bool    false	       enable bidirectional hardware flow
				       control
     hn	     str     hostname	       hostname
     ht	     bool    false	       terminal has real tabs
     hw	     bool    false	       hardwired (ignore hardware carrier-
				       detect)
     ig	     bool    false	       ignore garbage characters in login name
     im	     str     NULL	       initial (banner) message
     in	     str     `^C'	       interrupt character
     is	     num     unused	       input speed
     kl	     str     `^U'	       kill character
     lm	     str     login:	       login prompt
     ln	     str     `^V'	       ``literal next'' character
     lo	     str     /usr/bin/login    program to exec when name obtained
     m0	     str     NULL	       stty-style mode string used to write
				       messages
     m1	     str     NULL	       stty-style mode string used to read
				       login name
     m2	     str     NULL	       stty-style mode string used to leave

				       terminal as
     ms	     str     NULL	       stty-style mode string for default
				       modes
     nl	     bool    false	       terminal has (or might have) a newline
				       character
     np	     bool    false	       set 8-bit, no parity
     nx	     str     default	       next table (for auto speed selection)
     op	     bool    false	       terminal uses odd parity
     os	     num     unused	       output speed
     pc	     str     `\0'	       pad character (not currently used)
     pe	     bool    false	       use printer (hard copy) erase algorithm
     pf	     num     0		       delay between first prompt and follow-
				       ing flush (seconds)
     pl	     str     0		       ppp_direct name to use for PPP connec-
				       tions.
     pp	     str     0		       /usr/bin/ppp path to the ppp(8) pro-
				       gram.
     ps	     bool    false	       line connected to a MICOM port selector
     qu	     str     `^\'	       quit character
     ra	     bool    false	       do not reset modes to default before
				       starting
     rp	     str     `^R'	       line retype character
     rw	     bool    false	       do NOT use raw for input, use cbreak
     sp	     num     unused	       line speed (input and output)
     su	     str     `^Z'	       suspend character
     tc	     str     none	       table continuation
     to	     num     0		       timeout (seconds)
     tt	     str     NULL	       terminal type (for environment)
     ub	     bool    false	       do unbuffered output (of prompts etc)
     we	     str     `^W'	       word erase character
     xc	     bool    false	       do NOT echo control chars as `^X'
     xf	     str     `^S'	       XOFF (stop output) character
     xn	     str     `^Q'	       XON (start output) character

     If no line speed is specified, speed will not be altered from that which
     prevails when getty is entered.  Specifying an input or output speed will
     override line speed for stated direction only.

     Terminal modes to be used for the output of the message, for input of the
     login name, and to leave the terminal set as upon completion, are derived
     from the boolean flags specified and the ms string.  If the derivation
     should prove inadequate, any (or all) of these three may be overridden
     with one of the m0, m1, or m2 string specifications, which can be used to
     specify the stty(1)-style	strings.

     Should getty receive a null character (presumed to indicate a line break)
     it will restart using the table indicated by the nx entry. If there is
     none, it will re-use its original table.

     If the bi flag is set, getty will enable bidirectional use on the line.
     The line must support modem control, thus this option is incompatible
     with the hw flag.	In this mode, getty waits for carrier detect, then
     checks whether the line is locked for dial-out use.  If it is locked, it
     pauses until the line is unlocked.	 If the line is not locked, getty ac-
     quires the lock to prevent dial-out use until the line is hung up.

     The cl screen clear string may be preceded by a (decimal) number of mil-
     liseconds of delay required (a la termcap).

     The initial message, and login message, im and lm may include the charac-
     ter sequence %h or %t to obtain the hostname or tty name respectively.
     (%% obtains a single '%' character.)  The hostname is normally obtained
     from the system, but may be set by the hn table entry.  In either case it
     may be edited with he. The he string is a sequence of characters, each
     character that is neither '@' nor '#' is copied into the final hostname.
     A '@' in the he string, causes one character from the real hostname to be
     copied to the final hostname.  A '#' in the he string, causes the next
     character of the real hostname to be skipped.  Surplus '@' and '#' char-
     acters are ignored.

     When getty execs the login process, given in the lo string (usually
     ``/usr/bin/login''), it will have set the environment to include the ter-
     minal type, as indicated by the tt string (if it exists).	The ev string,
     can be used to enter additional data into the environment.	 It is a list
     of comma separated strings, each of which will presumably be of the form
     name=value.

     If a non-zero timeout is specified, with to, then getty will exit within
     the indicated number of seconds, either having received a login name and
     passed control to login,  or having received an alarm signal, and exited.
     This may be useful to hangup dial in lines.

     The terminal settings are no longer reset to system defaults before in-
     voking login(8).  You are now allowed to override them in the gettytab
     entry.

     Getty inherits its settings (including parity and character size) from
     the system defaults (set with the -D option to stty(1)).

     Even parity may be specified with ep or odd parity with op. The ap option
     disables input parity checking (and may be used in conjunction with ep or
     op). np sets 8-bit characters with no parity.

SEE ALSO
     login(8),	termcap(5),  getty(8).

BUGS
     In all cases, '#' or '^H' typed in a login name will be treated as an
     erase character, and '@' will be treated as a kill character.

     The he capability is stupid.

     The termcap format is horrid, something more rational should have been
     chosen.

HISTORY
     The gettytab file format appeared in 4.2BSD.

4.2 Berkeley Distribution	April 19, 1994				     3
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server BSDOS

List of man pages available for BSDOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net