device_set_desc_copy man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

DEVICE_SET_DESC(9)	 BSD Kernel Developer's Manual	    DEVICE_SET_DESC(9)

NAME
     device_set_desc, device_set_desc_copy, device_get_desc — access the
     description of a device

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     void
     device_set_desc(device_t dev, const char *desc);

     void
     device_set_desc_copy(device_t dev, const char *desc);

     const char *
     device_get_desc(device_t dev);

DESCRIPTION
     Manipulate the verbose description of a device.  This description (if
     present) is printed as part of the message when it is attached during
     autoconfiguration.	 The variation device_set_desc_copy() is used to set
     the description if the string passed is a temporary buffer which will be
     overwritten.  In this case, the system will copy the string, otherwise
     the pointer passed will be used directly.

SEE ALSO
     device(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net