device_printf man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

DEVICE_PRINTF(9)	 BSD Kernel Developer's Manual	      DEVICE_PRINTF(9)

NAME
     device_printf — formatted output conversion

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     device_printf(device_t dev, const char *fmt, ...);

DESCRIPTION
     The device_printf() function is a convenience interface to the printf(9)
     function.	It outputs the name of the dev device, followed by a colon and
     a space, and then what printf(9) would print if you passed fmt and the
     remaining arguments to it.

RETURN VALUES
     The device_printf() function returns the number of characters displayed.

SEE ALSO
     printf(3), printf(9)

BSD				April 21, 2003				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net