device_get_sysctl_ctx man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

DEVICE_GET_SYSCTL(9)	 BSD Kernel Developer's Manual	  DEVICE_GET_SYSCTL(9)

NAME
     device_get_sysctl_ctx, device_get_sysctl_tree — manipulate the sysctl oid
     tree for driver specific sysctl nodes

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     struct sysctl_ctx_list *
     device_get_sysctl_ctx(device_t dev);

     struct sysctl_oid *
     device_get_sysctl_tree(device_t dev);

DESCRIPTION
     The newbus system automatically adds a sysctl node for each device in the
     system.  This node can be accessed with the device_get_sysctl_tree()
     function.	The context for the node can be obtained with the
     device_get_sysctl_ctl() function.

SEE ALSO
     device(9)

AUTHORS
     This manual page was written by Warner Losh.

BSD				 May 23, 2006				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net