devclass_get_drivers man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

DEVCLASS_GET_DRIVERS(9)	 BSD Kernel Developer's Manual DEVCLASS_GET_DRIVERS(9)

NAME
     devclass_get_drivers — get a list of drivers in a devclass

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     devclass_get_drivers(devclass_t dc, driver_t ***listp, int *countp);

DESCRIPTION
     Retrieve a list of pointers to all driver instances currently in the dev‐
     class and return the list in *listp and the number of drivers in the list
     in *countp.  The memory allocated for the list should be freed using
     free(*listp, M_TEMP), even if *countp is 0.

RETURN VALUES
     Zero is returned on success, otherwise an appropriate error is returned.

SEE ALSO
     devclass(9), device(9)

AUTHORS
     This manual page was written by Nate Lawson.

BSD				 May 19, 2005				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net