copyin man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

COPY(9)			 BSD Kernel Developer's Manual		       COPY(9)

NAME
     copy, copyin, copyout, copystr, copyinstr — kernel copy functions

SYNOPSIS
     #include <sys/types.h>
     #include <sys/systm.h>

     int
     copyin(const void *uaddr, void *kaddr, size_t len);

     int
     copyout(const void *kaddr, void *uaddr, size_t len);

     int
     copystr(const void *kfaddr, void *kdaddr, size_t len, size_t *done);

     int
     copyinstr(const void *uaddr, void *kaddr, size_t len, size_t *done);

DESCRIPTION
     The copy functions are designed to copy contiguous data from one address
     to another.  All but copystr() copy data from user-space to kernel-space
     or vice-versa.

     The copy routines provide the following functionality:

     copyin()	   Copies len bytes of data from the user-space address uaddr
		   to the kernel-space address kaddr.

     copyout()	   Copies len bytes of data from the kernel-space address
		   kaddr to the user-space address uaddr.

     copystr()	   Copies a NUL-terminated string, at most len bytes long,
		   from kernel-space address kfaddr to kernel-space address
		   kdaddr.  The number of bytes actually copied, including the
		   terminating NUL, is returned in *done (if done is
		   non-NULL).

     copyinstr()   Copies a NUL-terminated string, at most len bytes long,
		   from user-space address uaddr to kernel-space address
		   kaddr.  The number of bytes actually copied, including the
		   terminating NUL, is returned in *done (if done is
		   non-NULL).

RETURN VALUES
     The copy functions return 0 on success or EFAULT if a bad address is
     encountered.  In addition, the copystr(), and copyinstr() functions
     return ENAMETOOLONG if the string is longer than len bytes.

SEE ALSO
     fetch(9), store(9)

BSD				January 7, 1996				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net