bus_generic_shutdown man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

BUS_GENERIC_SHUTDOWN(9)	 BSD Kernel Developer's Manual BUS_GENERIC_SHUTDOWN(9)

NAME
     bus_generic_shutdown — generic implementation of DEVICE_SHUTDOWN for
     busses

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     bus_generic_shutdown(device_t dev);

DESCRIPTION
     This function provides an implementation of the DEVICE_SHUTDOWN(9) method
     which can be used by most bus code.  It simply calls the
     DEVICE_SHUTDOWN(9) method of each child device attached to the bus.

RETURN VALUES
     Zero is returned on success, otherwise an appropriate error is returned.

SEE ALSO
     device(9), driver(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net