BOOTANY(8) BSD System Manager's Manual BOOTANY(8)NAMEbootany - install/update bootany master boot record
SYNOPSISbootany [-CLdfinSz] [-A part] [-F bootfile] [-s savembr] disk0 [disk1]
The bootany utility allows the installation of the bootany master boot
record (MBR) or editing of the partitions from which to boot on disk0.
The bootany MBR allows booting from up to 4 partitions on either of the
two disks accessible through the BIOS. Although BSD/OS, starting with
version 2, may be booted from either disk defined by the BIOS, other op-
erating systems may not be able to be booted from other than the first
disk0 should refer to the primary disk (e.g., /dev/rwd0c or /dev/rsd0c).
In order to boot from the second drive, it must be specified as disk1
With no options, bootany lists the current partitions from which to boot.
The options available are:
-A Set the partition defined by part, which must be a number between
1 and 4, as the current active partition.
-C Use the old style Cylinder/Head/Sector (CHS) boot record. The
CHS boot record must be used for booting from the second disk,
however, it does not support booting from a partition that is
more than 8GB into a disk. This is the default if two disks are
-d Treat the secondary drive as bootable with no FDISK table (i.e.
it is dedicated to BSD/OS.) In this case the disk1 argument may
-f Print the FDISK tables as well as bootany tables.
-F Use bootfile as the path to the file which contains the bootany
MBR instead of /usr/bootstraps/bootany.sys.
-i Ask for each of the partitions if they are bootable, and if so,
what to call them.
-L Use the new style Logical Block Addressing (LBA) boot record.
The LBA boot record does not support booting from the second
disk, however, it does support booting from a partition that is
more than 8GB into a disk. This is the default if only one disk
-n Install a new copy of bootany.sys.
-s Save a copy of the old MBR in savembr.
-S Used during the express install. Do not ask any questions, sim-
ply intuit the answers.
-z Zero the bootany tables. If specified with the -i flag, the ta-
bles are first zeroed and then interactive mode is entered.
The bootany program is called by disksetup(8) to install the BSD/OS MBR.
If no partitions are marked as bootable then the bootany bootstrap will
automatically try to boot what ever partition is marked active. It is
undefined as to what happens if no partition is marked active or the ac-
tive partition does not have a valid boot sector. In this case, the
bootany bootstrap will still attempt to load and boot some random sector
for the disk.
CHS vs LBA mode
Bootany will automatically determine if the currently installed bootany
record is the CHS or LBA mode record. When initializing a disk, the LBA
mode record is used unless -C is specified, a specific bootstrap is given
via -F, or disk1 is specified.
The CHS mode record uses BIOS INT 0x13 AH=0x02 to read sectors. This
call, while universal, is limited to 1024 cylinders, 256 heads and 63
sectors per track. The LBA mode record will use BIOS INT 0x13 AH=0x42 to
read sectors. This call is limited to 2^64 sectors. This call is not
universal (it is found in virtually all modern BIOSes) so this record can
fall back to the AH=0x02 if AH=0x42 is not supported by the BIOS. The
downside of the LBA record is that the extra code space needed to support
both types of interrupts prevents the record from supporting boots on the
SEE ALSOboot(8), disksetup(8)BSDI BSD/OS July 10, 2001 2