acct man page on BSDOS

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDOS logo
[printable version]

ACCT(5)			    BSD Programmer's Manual		       ACCT(5)

NAME
     acct - execution accounting file

SYNOPSIS
     #include <sys/types.h>
     #include <sys/acct.h>

DESCRIPTION
     The kernel maintains the following acct information structure for all
     processes. If a process terminates, and accounting is enabled, the kernel
     calls the acct(2) function call to prepare and append the record to the
     accounting file.

     /*
      * Accounting structures; these use a comp_t type which is a 3 bits base 8
      * exponent, 13 bit fraction ``floating point'' number.  Units are 1/AHZ
      * seconds.
      */
     typedef u_short comp_t;

     struct acct {
	     char    ac_comm[10];    /* name of command */
	     comp_t  ac_utime;	     /* user time */
	     comp_t  ac_stime;	     /* system time */
	     comp_t  ac_etime;	     /* elapsed time */
	     time_t  ac_btime;	     /* starting time */
	     uid_t   ac_uid;	     /* user id */
	     gid_t   ac_gid;	     /* group id */
	     short   ac_mem;	     /* memory usage average */
	     comp_t  ac_io;	     /* count of IO blocks */
	     dev_t   ac_tty;	     /* controlling tty */
     #define AFORK   0x01	     /* forked but not execed */
     #define ASU     0x02	     /* used super-user permissions */
     #define ACOMPAT 0x04	     /* used compatibility mode */
     #define ACORE   0x08	     /* dumped core */
     #define AXSIG   0x10	     /* killed by a signal */
	     char    ac_flag;	     /* accounting flags */
     };

     /*
      * 1/AHZ is the granularity of the data encoded in the comp_t fields.
      * This is not necessarily equal to hz.
      */
     #define AHZ     64

     If a terminated process was created by an execve(2),  the name of the ex-
     ecuted file (at most ten characters of it) is saved in the field ac_comm
     and its status is saved by setting one of more of the following flags in
     ac_flag: AFORK, ASU, ACOMPAT, ACORE and ASIG.

     The unusual coding of the comp_t fields gives a large range (more than 8
     years) in a small space (16 bits), at a small cost in accuracy.  To con-
     vert these fields, use the formula:
	   u = (v & 0x1fff) << (3 * (v >> 13))
     (where v is the comp_t value and u is the time in units of AHZ).  The
     largest possible value is 8191 * 8^7 or 17,177,772,032 units, which is
     about eight and a half years.  Note that the numbers remain exact through
     8191 units (just under 128 seconds), after which the low three bits of
     the value are dropped, so values that represent between 128 and 1023.875
     seconds are only accurate to the nearest 8/64 or 1/8th of a second.  An-
     other three bits disappear for each new power of 8, so values between
     1024 and 8191 seconds are only accurate to the second, and so forth.

SEE ALSO
     lastcomm(1),  acct(2),  execve(2),	 sa(8)

HISTORY
     An acct file format appeared in Version 7 AT&T UNIX.

BSDI BSD/OS		       February 12, 1998			     2
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server BSDOS

List of man pages available for BSDOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net