DEVICE_DETACH man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

DEVICE_DETACH(9)	 BSD Kernel Developer's Manual	      DEVICE_DETACH(9)

NAME
     DEVICE_DETACH — detach a device

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     DEVICE_DETACH(device_t dev);

DESCRIPTION
     Detach a device.  This can be called if the user is replacing the driver
     software or if a device is about to be physically removed from the system
     (e.g. for pccard(4) devices).

     The method should deallocate any system resources allocated during the
     DEVICE_ATTACH(9) method and reset the hardware to a sane state (i.e.,
     disable interrupts etc.)

RETURN VALUES
     Zero is returned on success, otherwise an appropriate error is returned.

SEE ALSO
     pccard(4), device(9), DEVICE_ATTACH(9), DEVICE_IDENTIFY(9),
     DEVICE_PROBE(9), DEVICE_SHUTDOWN(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net