BUS_WRITE_IVAR man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

BUS_READ_IVAR(9)	 BSD Kernel Developer's Manual	      BUS_READ_IVAR(9)

NAME
     BUS_READ_IVAR, BUS_WRITE_IVAR — manipulate bus-specific device instance
     variables

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     BUS_READ_IVAR(device_t dev, device_t child, int index,
	 uintptr_t *result);

     int
     BUS_WRITE_IVAR(device_t dev, device_t child, int index, uintptr_t value);

DESCRIPTION
     These two methods manage a bus specific set of instance variables of a
     child device.  The intention is that each different type of bus defines a
     set of appropriate instance variables (such as ports and irqs for ISA bus
     etc.)

     This information could be given to the child device as a struct but that
     makes it hard for a bus to add or remove variables without forcing an
     edit and recompile for all drivers which may not be possible for vendor
     supplied binary drivers.

RETURN VALUES
     Zero is returned on success, otherwise an appropriate error is returned.

SEE ALSO
     device(9), driver(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net