BUF_TIMELOCK man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

BUF_TIMELOCK(9)		 BSD Kernel Developer's Manual	       BUF_TIMELOCK(9)

NAME
     BUF_TIMELOCK — locks a buffer

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <sys/uio.h>
     #include <sys/bio.h>
     #include <sys/buf.h>

     int
     BUF_TIMELOCK(struct buf *bp, int locktype, char *wmesg, int catch,
	 int timo);

DESCRIPTION
     The BUF_TIMELOCK() function locks the given buffer, and limits the amount
     of time it will sleep to timo and OR's catch into the sleep's priority.
     wmesg is the wmesg used in the sleep.

     Its arguments are:

     bp	       The buffer to lock.

     locktype  Flags controlling the type of lock.  See lockmgr(9) for
	       details.

     wmesg     The wmesg used in any sleeps while acquiring the lock.

     catch     Priority OR'd into the sleep's priority.

     timo      The timeout for any sleeps encountered during the lock.

RETURN VALUES
     A value of 0 is returned on success.  See lockmgr(9) for details on non-
     zero return values.

SEE ALSO
     buf(9), BUF_LOCK(9), BUF_UNLOCK(9), lockmgr(9)

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 July 9, 2001				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net